2

I’m using Debian in its testing (9th) version.

I did a package upgrade two days ago, and since then Chromium doesn’t have any extensions installed. Flash isn’t working either (but it wasn’t working already before the upgrade).

chromium:amd64 was in version 55.0.2883.75-3 and now is in version 55.0.2883.75-6.

My ~/.config/chromium/Default/Extensions/ folder still has all of its extensions in there, but chromium doesn’t seem to want to use them.

If I try to install a new extension, I get the error, “installation is not enabled” but I can’t find any option that will let me enable extensions installation.

How do I get my extensions working again?

5

Non-packaged extensions have been disabled for security reasons, since version 55.0.2883.75-4 of the package. To re-enable them, you need to run Chromium with the --enable-remote-extensions option; if you want to do so permanently, you should copy /usr/share/applications/chromium.desktop to ~/.local/share/applications and add the option to the Exec line:

Exec=/usr/bin/chromium --enable-remote-extensions %U

Note that updating extensions has been (mistakenly) disabled; it's worth tracking #841401 for updates on that issue.

  • This doesn't work anymore on 70.0.3538.35. The message about not allowed installation from web site appears even after enabling switch as you suggested: /usr/lib64/chromium-browser/chrome --extra-plugin-dir=/usr/lib64/nsbrowser/plugins --enable-remote-extensions – kensai Oct 14 '18 at 6:06
  • @kensai extensions have seen quite a few changes in 70, you might need to adjust your preferences in the browser too (I haven’t checked yet). – Stephen Kitt Oct 14 '18 at 8:32
  • Actually by drag&drop cr extension directly it didn't work, but by loading as unpacked it worked. – kensai Oct 16 '18 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.