0

I just installed eclipse from the official arch repo and have this error

JVM terminated, Exit code=1
/usr/bin/java
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
...

I need it for the C debugger, any idea how to fix this ?

java -version
java version "1.7.0_111"
OpenJDK Runtime Environment (IcedTea 2.6.7) (Arch Linux build 7.u111_2.6.7-1-x86_64)
OpenJDK 64-Bit Server VM (build 24.111-b01, mixed mode)
3

Since you are using Arch linux, you have to first install jdk8-openjdk:

pacman -S jdk8-openjdk

and then set the default java version to java 8:

archlinux-java set java-8-openjdk/jre
2

Java version 1.8 is needed to run the latest Eclipse, it even says so in the error message you posted: -Dosgi.requiredJavaVersion=1.8. You have version 1.7. Is there some reason why you can't upgrade to OpenJDK 8?

  • No I just thought everything was taken care of by the dependency system and I had no clue what part of the java system had to be changed, I know nothing about java haha – ChiseledAbs Feb 12 '17 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.