0

When I first start playing an audio clip I get distorted sound then clears up. This behavior is consistent for all audio or video applications i.e. vlc, aplay, youtube etc. I have tried solutions as follows:

/etc/modprobe.d/snd_hda_intel.conf options snd_hda_intel power_save=0

sudo modprobe snd_hda_intel power_save=0

sudo /usr/bin/amixer -c 1 sset "Auto-Mute Mode" Disabled

Here is output of lspci sudo lspci | grep -i audio 00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40) 01:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1)

Here is /proc/modules cat /proc/modules | grep -i intel ghash_clmulni_intel 13259 0 - Live 0xffffffffa123b000 aesni_intel 69884 0 - Live 0xffffffffa1156000 lrw 13286 1 aesni_intel, Live 0xffffffffa10e3000 glue_helper 13990 1 aesni_intel, Live 0xffffffffa1123000 ablk_helper 13597 1 aesni_intel, Live 0xffffffffa10ec000 cryptd 20359 3 ghash_clmulni_intel,aesni_intel,ablk_helper, Live 0xffffffffa10ce000 snd_hda_intel 39987 7 - Live 0xffffffffa10f1000 snd_hda_codec 136428 4 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel, Live 0xffffffffa1100000 snd_hda_core 85362 5 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel,snd_hda_codec, Live 0xffffffffa10af000 snd_pcm 106416 4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core, Live 0xffffffffa1082000 snd 83432 24 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel, snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer, Live 0xffffffffa0e23000 crc32c_intel 22079 1 - Live 0xffffffffa00b3000

I have tried suggestions on https://fedoraproject.org/wiki/How_to_debug_sound_problems

Still cannot eliminate the issue

Has anyone have any ideas?

Thank You

  • Are you using an analog or a digital output? – CL. Feb 10 '17 at 7:40
  • If you are using Pulseaudio, first step is to stop Pulseaudio completely (verify with ps) and use ALSA directly (aplay -D front:foo, aplay -L for available devices) to take Pulseaudio out of the equation and find out if the problem is Pulseaudio, or ALSA/drivers. – dirkt Feb 10 '17 at 10:26
0

I powered down the computer instead of reset or reboot and issue went away.

the steps /etc/modprobe.d/snd_hda_intel.conf options snd_hda_intel power_save=0

sudo modprobe snd_hda_intel power_save=0

works just need to power down instead of reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.