1

I need gnome-terminal to open full-screen by default.

I overloaded it via /usr/local/bin/gnome-terminal:

#!/bin/dash
exec /usr/bin/gnome-terminal --full-screen "$@"

But this only works for xdg-mime (.desktop files with Terminal=true) and opening gnome-terminal from gnome-menu.

It does not work when I start new terminal by right-clicking in existing terminal and selecting "Open Terminal" option in the drop-down menu.

I tried to search in gnome-terminal source, but did not find where this menu option is handled.

How to start gnome-terminal full-screen in all cases?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.