0

An external hard disk sold as “INTENSO USB 3.0 4TB M/CNTR DSKTP HDD PK1” with the model number given by hdparm -I as ST4000DM000-1F2168 (so it's a Seagate Technology drive in the casing) just flat out ignores my power saving options set by hdparm.

root@igloo: hdparm -S 244 /dev/sdb        

/dev/sdb:
 setting standby to 244 (2 hours)

=> it still keeps spinning down after just 10 minutes. I absolutely verified that /dev/sdb is the right disk.

A clean solution to make the disk follow the power saving option is much preferred. If this is not possible what would be the best workaround?

  • @JeffSchaller: before I set anything with hdparm, it also spins down after ten minutes – wolf-revo-cats Feb 9 '17 at 23:14
  • @JeffSchaller: Is it some hard-coded spin-down time? – wolf-revo-cats Feb 9 '17 at 23:15
  • Oh! Sorry, I misread your intention. – Jeff Schaller Feb 9 '17 at 23:19
  • 1
    check out this answer to use hdparm -B 254 first. – meuh Feb 10 '17 at 9:26
3

There is the option hdparm -Z to "disable the automatic power-saving function of certain Seagate drives (ST3xxx models?), to prevent them from idling/spinning-down at inconvenient times."

Although yours is a Seagate ST4xxx model it may work for you too.

There's also hdparm -B 254 that will "Get/set Advanced Power Management feature, if the drive supports it." (Taken from What could be causing my hard drive to spin down, which suggests that this setting will then allow the hdparm -S feature to work as expected.)

  • Thank you. Sadly, the -Z gives me an error message. – wolf-revo-cats Feb 9 '17 at 23:32
  • ok, hdparm -B 254 seems to work. Does it have to be set again at every system boot? – wolf-revo-cats Feb 10 '17 at 16:53
  • @wolf-revo-cats I would imagine so. On my Debian (wheezy) box there are a couple of places to put these configuration statements, though: /etc/default/hdparm and /etc/hdparm.conf. If you're on a different distro I assume there'll be something similar. – roaima Feb 10 '17 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.