1

My disk storage running on Solaris + ZFS and i can't delete a file from my cifs share. I tried from Windows + Solaris nothing works... I was thinking someone is using the file and i close my cifs with (zfs set smbshare=off) nothing changed..

My file is:

-rwxrwxrwx+ 1 root root 31584256 Feb 9 14:34 'A. Test2017-02-09T020046.vib'*

rm -rf 'A. Test2017-02-09T020046.vib''

rm: cannot remove 'A. Test2017-02-09T020046.vib': Permission denied

I'm root, i have every possible permission on this system but even the root can't delete this file! How is this possible?

Edit: Maybe nbmand causing this problem? The SMB protocol assumes mandatory locking, but UNIX traditionally uses advisory locking. The Oracle Solaris OS can be configured to use mandatory locking on a per mount basis by using the non-blocking mandatory locking (nbmand) mount option.

  • 1
    Can you post the output from zfs get all filesystem, where filesystem is your ZFS filesystem? – Andrew Henle Feb 9 '17 at 17:31
0

Is it mounted as a read only filesystem? If not, my best guess is that perhaps you're using the vscan option on the dataset, and that a virus scanner has flagged it and the vscand service locked the file down.

Can you do something like file 'A. Test2017-02-09T020046.vib' to see if the file can be read.

0

I still have no answer but i think "Veeam backup" locking the file someway. After reboot OS im able to delete the file.. Problem solved with reboot but this is really bad thing for Storage! I hope this problem will not repeat again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.