0

I upgraded my GCC from 4.4.7 to 4.8.2.

So I removed GCC 4.4.7 by using:

rpm -e --nodeps gcc-c++-4.4.7.......  libgcc-4.4.7.......  gcc-4.4.7........

Then I manually installed 4.8.2:

./configure make && make install

and had no problems with it.

Then I run:

yum check

Now there is a whole list of missing dependencies like this:

libpanelappletmm-2.26.0-3.el6.x86_64 has missing requires of libgcc_s.so.1(GCC_3.0)(64bit)
libplist-1.2-1.el6.x86_64 has missing requires of libgcc_s.so.1()(64bit)
libplist-1.2-1.el6.x86_64 has missing requires of libgcc_s.so.1(GCC_3.0)(64bit)
libsigc++20-2.2.4.2-1.el6.x86_64 has missing requires of libgcc_s.so.1()(64bit)
libsigc++20-2.2.4.2-1.el6.x86_64 has missing requires of libgcc_s.so.1(GCC_3.0)(64bit)
libstdc++-4.4.7-17.el6.x86_64 has missing requires of libgcc_s.so.1()(64bit)
libstdc++-4.4.7-17.el6.x86_64 has missing requires of libgcc_s.so.1(GCC_3.0)(64bit)
libstdc++-4.4.7-17.el6.x86_64 has missing requires of libgcc_s.so.1(GCC_3.3)(64bit)
libstdc++-4.4.7-17.el6.x86_64 has missing requires of libgcc_s.so.1(GCC_4.2.0)(64bit)
libtiff-3.9.4-18.el6_8.x86_64 has missing requires of libgcc_s.so.1()(64bit)

I then checked libgcc_s.so.1 was installed at /usr/local/lib64 and /usr/local/gcc-4.8.2/lib64.

Would this method of upgrading causing any issue or the error message is just because yum didn't recognize gcc is actually installed?

2
  • If I remember correctly this file is for static linking (even though it is a shared object library, which is counter-intuitive) . you might need to add --enable-static on the configure command (Or something like that)
    – Chunko
    Feb 12 '17 at 16:16
  • Try to run 'ldconfig -v' after your install. If you installed to somewhere like /use/local, try to add those two /usr/local paths to /etc/ld.so.conf and then run ldconfig
    – Chunko
    Feb 12 '17 at 16:18
0

Since no one is answering the question,Here are some of my quick guesses:

1 There will be problem if I removed older version of gcc on older version of linux platform,some of the program still rely on it.

2 libgcc_s.so.1 exists in both older and newer version of gcc but their contents were differentiated within the file.

3 It will cause other packages which relys on older version of gcc unable to install

Am I right?

1
  • libstdc++- comes with GCC. The best thing to do is not uninstall the system GCC. (Or put it back). Then existing apps won't break. But you can build stuff with the new GCC from /usr/local/bin by putting that earlier in your path
    – Chunko
    Feb 12 '17 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.