I wanted to update my system (Slackware current) which was in multilib. Before updating, I tried to remove all packages (compat32 and multilib). Big mistake !!! This have broken some crucial symlinks and give me now a kernel panic when i trie to boot it.

I have tried several methods, including this one But it does not work since I no longer have the original disc

Can someone tell me what is the proper way to recover the installation in this situation?

  • When something does that badly wrong, it's time to take the old penguin out back and install a new one. – DepressedDaniel Feb 9 '17 at 1:18

since you can't boot your system, you need some other medium - cd or usb. there is no other magic way to boot unbootable system.

basically what you have to do is:

  1. boot your machine (slackware installer).
  2. mount your partitions and chroot to system / dir.
  3. install packages you removed (download them from some slackware mirror and copy, ie on usb drive).

in details:

  1. boot from slackware install disc or usb drive.
  2. make some directory for your broken system (mount point), ie:

    mkdir /mnt
  3. mount root partition (let's say it's sda2) to created directory, ie:

    mount /dev/sda2 /mnt
  4. if your system is spread on many partitions (/boot, /var etc directory on separate partition) - mount them too! let's say your /boot is on sda1 and /var on sda3:

    mount /dev/sda1 /mnt/boot
    mount /dev/sda3 /mnt/var
  5. copy (ie on usb drive) packages you removed in some accessible place on your system partition, ie /mnt/root.

  6. "switch" to your system partition:

    chroot /mnt
  7. install packages, now they are in /root

it is done :)

next, to clean up:

  1. exit chroot environment (Ctrl+D or logout).
  2. umount partitions you mounted in 4. and then(!) 3, ie:

    umount /mnt/var
    umount /mnt/boot
    umount /mnt
  3. reboot to your hopefully rescued slackware os :)

  • 1
    That's what I'm already trying to do. I have a swap (/dev/sda1) and (dev/sda2) for /. when mounting mount /dev/sda2 /mnt and chroot /mnt /bin/bash -l in mnt i have error: chroot; failed to execute /bin/bash no such file or directory. The install dvd is not the original, Is that this error comes from this? – antuan sehikyan Feb 9 '17 at 8:05
  • 1
    when you chroot - you change your root partition and start new shell. for some reason there is no /bin/bash shell on your system. btw in most cases you don't have to specify /bin/bash when you chroot. by default chroot will use /bin/sh shell. please try chroot /mnt. if you get the same error, try with other shell, ie: chroot /mnt /bin/zsh. there are several other shells (/bin/tcsh, /bin/zsh, /bin/ksh etc), they are listed in /etc/shells file. one of them should work. – rsm Feb 9 '17 at 14:52
  • 1
    The problem is solved, that's what I said, it comes from the version. thank you for your help – antuan sehikyan Feb 10 '17 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.