0

I'm running vncserver and getting this prompt:

New 'Middle:1 (root)' desktop at :1 on machine Middle

starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/Middle:1.log

Use xtightvncviewer -SecurityTypes VncAuth -passwd /root/.vnc/passwd :1 to connect to the VNC server.

But when I try to connect using my VNC viewer on my windows machine I get The connection was refused by the computer.

This problem happened because I had edited my /etc/vnc/xstartup file since I had a grey screen every time I tried to log in the VNC server so I followed every solution I could find but they didn't fix it... Maybe made it worse.

My /etc/vnc/xstartup file: xstartupfile

in ragardes to sgargel's answer: enter image description here

about the "can't open file Xresources" - its in my /etc/X11/ folder

What can I do ?

  • Check if the vncserver is running and on which port is binding with netstat -antpl . Check your vncserver logfile and if there is some firewall rule that reject traffic. – sgargel Feb 8 '17 at 9:23
  • I have updated my question with the information you need, I cant find the log file where it is specified to be, its not even being created. And I dont have firewall, neither does the vnc viewer machine. It seem like a vnc server is running, but I cant connect to it, it's something in the configurations that I know nothing about.. – eyal360 Feb 8 '17 at 9:57
  • Error seems to be on /etc/.vnc/xstartup but you attached your /etc/vnc/xstartup (without dot). It's a typo error? In netstat seems that vnc isn't listening on 0.0.0.0:5901 – sgargel Feb 8 '17 at 10:02
  • I dont think so, its a directory-lookup type of command.. I saw that in many other tutorials I have seen.. I dont think that is the issue – eyal360 Feb 8 '17 at 10:06
  • 1
    That worked , I can now connect through VNC, but the screen is all grey, any way to fix that? – eyal360 Feb 9 '17 at 8:40
0

The problem is that your VNC server is only binding to localhost

A way to fix it was shown in this answer .

  • I dont think that is the problem , as I can access from any local IP to the machine without using localhost and ssh tunneling, but the grey screen still appears.. thanks for your help. – eyal360 Feb 9 '17 at 10:02
  • Ok so I have Raspbien Jessie running and VNC is working perfect... guess Linux with R.PI3 isnt the best option for VNCviewer/Server... – eyal360 Feb 10 '17 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.