2

I use Lubuntu. My Windows partitions mount every time I use the Linux OS; is there any way to keep them from auto-mounting?

How can I mount a partition when I want to?

/dev/sda5: UUID="B9C1-DD76" TYPE="vfat" PARTUUID="0aa163f7-06"
2
  • add more detail to your question like, paste the content of fstab file and which partition is windows one.
    – Rakesh.N
    Feb 8, 2017 at 3:33
  • @Rakesh.N Take a look at the question, I added the partition.
    – tharmund
    Feb 8, 2017 at 8:55

1 Answer 1

2

To keep the filesystem from being mounted automatically, you may add a line to your /etc/fstab file, using e.g. sudo nano /etc/fstab or whatever editor you prefer. The line should read

UUID=B9C1-DD76 /some-path vfat defaults,noauto,user

where /some-path means the directory where the filesystem should be mounted. This must exist and be writeable by you. Option noautosays the filesystem will not be mounted automatically, and user says that normal users are allowed to mount the filesystem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .