2

I have recently installed Arch Linux on my system and I want to set up the Dropbox client so that I may sync some of my files with the cloud. I am trying to compile the client from source as instructed by How do I build the Dropbox installer for Linux?. However I have a problem, it instructed my to install pygtk, and I have done so with pacman, however even after a restart running:

cd ./nautilus-dropbox-2015.10.28; ./configure; make; make install;

Only returns with:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for fgrep... /usr/bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for pkg-config... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for NAUTILUS... yes
checking for GLIB... yes
checking for python... /usr/bin/python
checking for rst2man... python rst2man.py
checking for pygtk... no
configure: error: couldn't find pygtk
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.

My system is up-to-date, what am I missing?

Information Update:

I would rather not provide the entire log as there is a lot of system configuration information there which I would rather not post online just in case, but here is what I believe to be the relevant part of the config.log requested:

configure:10713: checking for python
configure:10731: found /usr/bin/python
configure:10743: result: /usr/bin/python
configure:10754: checking for rst2man
configure:10785: result: python rst2man.py
configure:10799: checking for pygtk
configure:10812: result: no
configure:10814: error: couldn't find pygtk

But this error message doesn't really help me to understand what the issue is and why it can't find pygtk.

6 Answers 6

2

I came across the same problem, modifying the symbolic link to point python to python2.7 didn't work for me.

What worked for me was to run the following command to replace all occurrences of python with python2 within each file in the nautilus-dropbox-2.10.0 folder:

grep -rl python . | xargs sed -i 's/python/python2/g'

After that I ran the configure, make and make install commands as usual.

1

I came across this question while trying the same thing, and I think I know why this is happening.

In Arch Linux, running Python will call Python 3 rather than Python 2, unlike almost all other Linux OS. I really like Arch Linux, but I honestly have no idea why Python 2 isn't the default as this just complicates the whole process of building from source. You probably shouldn't replace the python symlink with one pointing to Python 2 because it's likely going to mess up everything else.

Anyways, I took a look at configure and it checks for pygtk by attempting to import it within python. In Python 2, running import pygtk works, while in Python 3, running it will lead to an error:

>>> import pygtk
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'pygtk'

Now how do we resolve this? I'm not exactly sure. I tried changing the PYTHON variable to point to python2 only within dropbox, but this doesn't seem to work.

The answer to your original question is that you're not missing anything, only that it's not working because python points to /usr/bin/python3.

1

I somewhat managed to solve the problem, as you said it was that the configure was calling Python 3 and not Python 2.

Just go to you binaries folder cd /usr/bin and modify the symbolic link from Python 3 to Python 2 keeping a backup to restore in once the installation is complete:

sudo mv python python.old
sudo ln -s python2.7 python

You can then go back to your package folder and run the make to build dropbox. Once you're finished you have to revert back the symbolic link to Python 3 otherwise you're going to have some issues with your system:

cd /usr/bin
sudo mv python.old python

You will now need to tell the dropbox app to not follow the /usr/bin/python symbolic link and instead follow the already existing /usr/bin/python2 symbolic link. To do that just open the /usr/bin/dropbox file in your favorite text editor (use sudo or you won't be able to edit it) and change the first line from #!/usr/bin/python to #!/usr/bin/python2.

You should now be able to start the dropbox API by typing dropbox start without any compatibility problems.

0

Look at config.log, it contains a detailed transcript of what configure ran. That way you'll get the details behind “checking for pygtk”… and the details for “no”. The last few lines are the relevant ones; the problem starts after the line containing “checking for pygtk”.

Usually the content of config.log is sufficient to understand the problem. If it isn't, add it to your question.

1
  • The log isn't much more helpful than anything else, I have updated my question. If there is a different relevant section of the log which I need to attach then please let me know.
    – user103789
    Feb 21, 2017 at 22:51
0

I came across this recently, and what I found (apart from what is suggested in previous answers) is that configure script tries to import the gtk module, not pygtk as one could expect.

$as_echo_n "checking for pygtk... " >&6; }

cat <<EOF | python
try:
 import gtk
except:
 exit(1)
else:

A workaround is to substitute de gtk for pygtk in that line

sed -i 's/ gtk/ pygtk/g' nautilus-dropbox-2.10.0/configure

I know is not the same package version as in the original question, but as the error message is the same, it could be helpful for those directed to this same question.

0

I found this article while building Dropbox (https://linux.dropbox.com/packages/nautilus-dropbox-2.10.0.tar.bz2) on a remote CentOS 7 machine.

While I have installed pygtk using yum install pygtk2 pygtk2-devel, the the ./configure command still exits with the statement:

checking for pygtk... no
configure: error: couldn't find pygtk

Opening the a python prompt and manually import gtk shows the reason why:

[user@computer ~]# python
Python 2.7.5 (default, Jun 20 2019, 20:27:34) 
[GCC 4.8.5 20150623 (Red Hat 4.8.5-36)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtk
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 64, in <module>
    _init()
  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 52, in _init
    _gtk.init_check()
RuntimeError: could not open display
>>> 

It seems that importing gtk needs a valid DISPLAY set.

Starting a ssh-session with -x (X11-forwarding) makes this part work.

You must log in to answer this question.