4

I am using RHEL 7.3 on AWS EC2:

$ cat /etc/*-release
NAME="Red Hat Enterprise Linux Server"
VERSION="7.3 (Maipo)"

I would like to install OpenVPN client and was following these directions. I started by sudo yum update which completed fine. Then

$ sudo yum install epel-release
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
rhui-REGION-client-config-server-7                                                                                     | 2.9 kB  00:00:00
rhui-REGION-rhel-server-releases                                                                                       | 3.5 kB  00:00:00
rhui-REGION-rhel-server-rh-common                                                                                      | 3.8 kB  00:00:00
No package epel-release available.
Error: Nothing to do
$ sudo yum install openvpn easy-rsa
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
No package openvpn available.
No package easy-rsa available.
Error: Nothing to do

How can I install OpenVPN client? Do I need add another yum repo? I also tried the suggestions from this post, without success.

UPDATE: I was actually able to get past epel. i did yum-config-manager --enable epel. Then I also successfully installed easy-rsa: yum install easy-rsa. However, when I did yum install openvpn (yum install openvpn), i got:

Error: Package: openvpn-2.3.14-1.el6.x86_64 (epel)
           Requires: dev >= 3.3.2-5
11
  • No: Error getting repository data for epel, repository not found when run that command
    – amphibient
    Feb 7, 2017 at 16:09
  • 1
    Run yum install –y https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm then yum-config-manager --enable epel update and try to install openvpn
    – GAD3R
    Feb 7, 2017 at 16:14
  • I got http://mirror.cc.columbia.edu/pub/linux/epel/6/x86_64/repodata/bd307163e8ee8d968bde0c0214c5d44daaa3419cea7a084bb61b57fd1941b01f-primary.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found
    – amphibient
    Feb 7, 2017 at 16:15
  • I was actually able to get past epel. i did sudo yum-config-manager --enable epel. however, when I did yum install openvpn, i got Error: Package: openvpn-2.3.14-1.el6.x86_64 (epel) Requires: dev >= 3.3.2-5
    – amphibient
    Feb 7, 2017 at 16:21
  • also, see the update I just posted
    – amphibient
    Feb 7, 2017 at 16:23

2 Answers 2

5

Remove epel-6 repo

yum remove epel-release

Enable epel-7 repo:

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.‌​noarch.rpm
rpm -ivh epel-release-latest-7.‌​noarch.rpm

Or

wget https://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-9.noarch.rpm
rpm -ivh epel-release-7-9.noarch.rpm

edit the /etc/yum.repos.d/epel.repo file and make sure you have enabled=1

or run yum-config-manager --enable epel

then install openvpn:

yum update
yum install openvpn easy-rsa
2
  • 1
    I had to do the 2nd option for Enable epel repo BTW
    – amphibient
    Feb 7, 2017 at 16:41
  • Same with "default" curl: curl -Sso epel-release-latest-7.noarch.rpm https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm Jun 20, 2018 at 15:03
2

If you're intending to use yum, you might want to skip the wget and just download the package with yum. Otherwise, when you run yum again, it will give you a warning about packages being updated/installed outside of yum.

yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.