I recently installed Antergos with Xfce. However, the default cursor is massive when it's over a window that isn't the OS itself. So, if I'm within the file manager everything looks normal. With Chrome/VSCode/Terminator the cursor is drastically bigger.
Within my appearance settings it is set to 16 which is the lowest.
Any ideas?

  • 1
    Comments are not for extended discussion; this conversation has been moved to chat.
    – terdon
    Feb 9, 2017 at 11:48

2 Answers 2


On Xfce4, after I had used a 4K display, my mouse cursor size was also too large. I just went to "Settings -> Mouse and Touchpad -> Theme", Cursor Size said 16 with down arrow disabled. I increased the size to 32, then back to 16 and the size of the cursor was back to the right (i.e. small) size.

  • 1
    worked for me. thank you
    – Sergei G
    Apr 29, 2020 at 15:43
  • Yeah, just bump it up and bring it back.
    – t56k
    May 23, 2020 at 22:12
  • 3
    this worked only partially for me: now the browser window also show a normal cursor, but some other windows (including the terminal) still show a huge cursor.
    – msb
    Jul 12, 2020 at 3:09
  • It was strange that it started to happen without any reason and only for thunderbird and xfce-terminal. Weird.. toggling the theme settings worked.
    – helvete
    Oct 5, 2021 at 8:56
  • I've found this fixes the default cursor, but not other cursors like the "pointing hand" and window resize. Sep 19 at 15:38

It seems like you have different cursor configurations for your Desktop Environment (Xfce) and your X server (in this setup: your desktop).

As Xfce relies on GTK, it'll store it's settings to the GTK settings. There are some other apps that don't read this and need to be configured.

You can create a ~/.Xresources file and inser settings regarding those apps. For example setting your cursor:

!Xcursor.theme: cursor-theme
Xcursor.size: 16

(Lines beginning with an ! are comments.)

After that, you need to load this configuration by typing ...

$ xrdb ~/.Xresources

This requires xorg-xrdb to be installed.

Note, that not all apps may apply these changes immediately, so you need to restart these apps. (Or if it doesn't change for the desktop, try restarting X.)

You can find more info about X resources and settings in the Glorious Arch Wiki page.

If you want to experiment a little bit with X resources, I recommend you installing Urxvt terminal, which is a very good terminal itself and gets its configuration from the X resources. How to change stuff is documented in the linked article. To test changes, $ xrdb ~/.Xresources it, close and open terminal again to see effects.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .