3

I can't get my WLAN working on a fresh Debian 8.7.1 64bit installation. Maybe you can help me find the issue. The card I am using is an Intel 8260 WLAN/Bluetooth card:

# lspci | grep Wire
04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

I installed iwlwifi with apt and loaded the module:

# modprobe -r iwlwifi ; modprobe iwlwifi

lsmod output:

# lsmod | grep wif
iwlwifi                96547  0
cfg80211              413730  1 iwlwifi

iwconfig:

# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

So what am I missing?! I am getting the feel it's because of the firmware not supporting the Kernel?

root@dfog:/home/irrgeist# uname -a
Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1 (2016-12-30) x86_64 GNU/Linux

I rebooted the system.

Edit:

#ls /lib/firmware/
av7110                iwlwifi-3160-8.ucode     iwlwifi-7260-8.ucode
carl9170-1.fw         iwlwifi-3160-9.ucode     iwlwifi-7260-9.ucode
cis                   iwlwifi-3945-2.ucode     iwlwifi-7265-8.ucode
dsp56k                iwlwifi-4965-2.ucode     iwlwifi-7265-9.ucode
hp                    iwlwifi-5000-2.ucode     iwlwifi-8000C-13.ucode
intel                 iwlwifi-5000-5.ucode     iwlwifi-8265-22.ucode
isci                  iwlwifi-5150-2.ucode     keyspan_pda
iwlwifi-1000-5.ucode  iwlwifi-6000-4.ucode     RTL8192E
iwlwifi-100-5.ucode   iwlwifi-6000g2a-5.ucode  RTL8192SU
iwlwifi-105-6.ucode   iwlwifi-6000g2a-6.ucode  rtl_nic
iwlwifi-135-6.ucode   iwlwifi-6000g2b-6.ucode  rtlwifi
iwlwifi-2000-6.ucode  iwlwifi-6050-4.ucode     usbduxfast_firmware.bin
iwlwifi-2030-6.ucode  iwlwifi-6050-5.ucode     usbdux_firmware.bin
iwlwifi-3160-7.ucode  iwlwifi-7260-7.ucode     usbduxsigma_firmware.bin

sources.list

#

# deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 NETINST Binary-1 20170116-10:57]/ jessie main

#deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 NETINST Binary-1 20170116-10:57]/ jessie main

deb http://ftp.de.debian.org/debian/ jessie main non-free contrib
deb-src http://ftp.de.debian.org/debian/ jessie main non-free contrib

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.de.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian/ jessie-updates main contrib non-free

deb http://ftp.de.debian.org/debian/ jessie-backports main contrib non-free
3

According to the official website the Intel® Dual Band Wireless-AC 8260 work on kernel version 4.1 and higher.

You can add the backports repo to your sources.list

deb http://ftp.debian.org/debian jessie-backports main non-free

Update and run apt-cache search linux-image to get the available linux-image then install a kernel > 4.1

e,g :

apt-get install linux-image-4.8.0-0.bpo.2-amd64

or the latest kernel version:

apt-get install linux-image-4.9.0-0.bpo.1-amd64-unsigned

Reboot your system and install the firmware-iwlwifi needed to get the Bluetooth working :

apt-get install -t jessie-backports firmware-iwlwifi

The wifi firmware iwlwifi-8000C-16.ucode is included on the firmware-iwlwifi package , also it can be added through :

wget https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-8000-ucode-16.242414.0.tgz
tar xvf iwlwifi-8000-ucode-16.242414.0.tgz
cd iwlwifi-8000-ucode-16.242414.0
cp iwlwifi* /lib/firmware

EDIT

To solve the black screen after installing the new kernel reinstall xserver-xorg-video-intel from backports , to get more info about the problem , see the answer of Stephen Kitt.

apt-get remove xserver-xorg-video-intel 
apt-get install -t jessie-backports xserver-xorg-video-intel
  • Just did this with ´apt-get install -t jessie-backports linux-image-amd64´ and rebooted...now I get a black screen while booting (it's loading the new Kernel) ... first time I do this kind of task x_X ... switching to TTY works, startx says, it could not find a monitor x_X Guess I have to remove it and do it your way... – DoubleVoid Feb 6 '17 at 19:59
  • Boot the 3.16 kernel from the advanced option of debian on GRUB menu then install the new kernel using : apt-get install linux-image-4.9.0-0.bpo.1-amd64-unsigned – GAD3R Feb 6 '17 at 20:03
  • Did it, same problem though :( – DoubleVoid Feb 6 '17 at 20:08
  • 1
    run apt-get remove xserver-xorg-video-intel && apt-get install -t jessie-backports xserver-xorg-video-intel More info here – GAD3R Feb 6 '17 at 20:14
  • 1
    Ah now it works, just saw your edit about installing the firmware from the backports...wow! Thank you very much!! :D – DoubleVoid Feb 6 '17 at 20:34
2

according to intel-supports-site

you need higher kernel-version (4.1). Try kernel from backports.

1

I went to the synaptic package manager and typed in iwlwifi, then hit search. this gave me the option of firmware-iwlwifi, which I selected and installed. then I rebooted wifi now seen, I am connected right now.

Debian stretch 9, with the intel 8260 WLAN/Bluetooth card (I am new to Debian this month but have been using Ubuntu, Mint, Manjaro, since 2012).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.