1

I'm trying to enable Arabic support on VM. I set the locale to ar_SA.utf8. What I want is to type Arabic characters in Gedit to test. After setting locale, I log off, and when I tried to login it shows gibberish as shown in image

enter image description here

I also change the language to French and it's working well

enter image description here

And localectl status

> [root@mserver (~)]# >  localectl status    System Locale:
> LANG=fr_FR.UTF-8
>        VC Keymap: us-acentos
>       X11 Layout: us
>        X11 Model: pc105
>      X11 Variant: intl

And Yum Langlist output shows Arabic Language is install already

[root@mserver (~)]# >  yum langlist
Modules complémentaires chargés : aliases, changelog, langpacks, ovl, product-id, search-disabled-repos, subscription-manager, tmprepo, verify, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Installed languages:
        Arabic
  • 2
    My best guess would be that you also need some fonts to match. – schaiba Feb 6 '17 at 11:04
0

RedHat officially supports 22 languages on RHEL7, Arabic is not one of the officially supported languages though. If Arabic locale is installed, you should still be able to see the characters rendered (maybe not in the menus or various other window panels) so long as you have some Arabic fonts installed, e.g., fonts-hosny-amiri.

You should be able to search for Arabic fonts with Yum:

For example: yum search amiri or yum search naskh

Note: Apologies for not noticing the comments section, @schaiba 's comment would have constituted an answer, in my opinion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.