5

Hello I want to add the Armenian language in FreeBSD. Here are my configs

/etc/login.conf

armenian|Armenian Users Accounts:\
        :charset=ARMSCII-8:\
        :lang=hy_AM.ARMSCII-8:\
        :tc=default:  

Execute cap_mkdb /etc/login.conf

/home/david/.login_conf

me:\
        :charset=ARMSCII-8:\
        :lang=hy-AM.ARMSCII-8:

/etc/ttys

console none                            unknown off secure
#
ttyv0   "/usr/libexec/getty Pc"         xterm   on  secure
  #Virtual terminals
ttyv1   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv2   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv3   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv4   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv5   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv6   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv7   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv8   "/usr/local/bin/xdm -nodaemon"  xterm   off secure
  #Serial terminals
  #The 'dialup' keyword identifies dialin lines to login, fingerd etc.
ttyu0   "/usr/libexec/getty 3wire"      vt100   onifconsole secure
ttyu1   "/usr/libexec/getty 3wire"      vt100   onifconsole secure
ttyu2   "/usr/libexec/getty 3wire"      vt100   onifconsole secure
ttyu3   "/usr/libexec/getty 3wire"      vt100   onifconsole secure
  # Dumb console
dcons   "/usr/libexec/getty std.9600"   vt100   off secure

/etc/rc.conf

mousechar_start=3
keymap="hy.armscii8"
scrnmap="armscii8-r2cp866"
font8x16="armscii8-8x16"
font8x14="armscii8-8x14"
font8x8="armscii8-8x8"

/usr/share/syscons/fonts/*

-r--r--r--  1 root  wheel   5067 Aug  8  2016 armscii8-8x14.fnt
-r--r--r--  1 root  wheel   5775 Aug  8  2016 armscii8-8x16.fnt
-r--r--r--  1 root  wheel   2949 Aug  8  2016 armscii8-8x8.fnt

Please help.When I am typing in armenian shows ???????.What I am doing wrong?

  • 1
    What is the actual question? – schaiba Feb 6 '17 at 10:16
  • 2
    More to the point, what makes you think it isn't working? – a CVn Feb 6 '17 at 10:57
5

The problem was solved,solution is to add several lines in /etc/login.conf:

    :charset=UTF-8:\
    :lang=en_US.UTF-8:\

Thanks to everyone ))

  • 1
    For more information, read freebsd.org/doc/handbook/using-localization.html – mareoraft Feb 7 '17 at 22:37
  • 1
    Depending on your specific situation, you may want to be setting the LANG environment variable. This can be done with export LANG="en_US.UTF-8" (or whichever language you prefer). You can add this to your ~/.profile or similar if you want it to be set every time you open a login shell. – mareoraft Feb 7 '17 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.