0

I run Debian Jessie (amd64) on my host. I use Debian Jessie (amd64) as guest (with qemu-kvm).

I run kvm as:

/usr/bin/kvm -monitor stdio \
             -smp 2 -soundhw ac97 -vga std \
             -enable-kvm -m 512 \
             -drive file=usb32g.qcow2,cache=writeback,aio=threads \
             -boot once=d,menu=off \
             -net nic,vlan=0,macaddr=00:5a:2f:09:1a:99 -net user,vlan=0 \
             -no-quit -name "deb-x64" \
             -bios /usr/share/ovmf/OVMF.fd

And when i start VM, efi-firmware reported:

Boot Failed. debian

As i can guess, efi-firmware can find partition with efi bootloader, but something went wrong. BTW, if i supply netinst iso-image, efi-firmware boot the debian-installer, i can accsess shell, chroot to system installed on usb32g.qcow2, reinstall grub-efi and run update-grub, but it has no effect.

The EFI-partition is located on primary MBR-partition with number 2 (i. e. /dev/sda2), and root file system is located on logical MBR-partition (i. e. /dev/sda6).

Any suggestions?

0

I had the same problem as you had and for me the solution was, that there seems to be a bug in VB, that you can't use SAS as controller. So I changed it to SATA and it works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.