0

After reading that Debian testing is more popular with desktop users than Debian stable, i decided to upgrade from stable to testing. I replaced all instances of "jessie" with "testing" with the command "sed -i 's/jessie/stable/g' /etc/apt/sources.list. Then, I did the upgrade with the command "sudo apt-get update && sudo apt-get upgrade". Now, when I try to install packages or upgrade, I get the following output:

# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 console-setup : Depends: keyboard-configuration (= 1.123) but 1.156 is installed
 console-setup-linux : Depends: keyboard-configuration (= 1.123) but 1.156 is installed
 libpurple-bin : Depends: libpurple0 but it is not installed
 systemd : Depends: libsystemd0 (= 215-17+deb8u5) but 232-8 is installed
 udev : Depends: libudev1 (= 215-17+deb8u5) but 232-8 is installed
E: Unmet dependencies. Try using -f.

So naturally, I followed the instructions and tried using -f:

# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 console-setup : Depends: keyboard-configuration (= 1.123) but 1.156 is installed
 console-setup-linux : Depends: keyboard-configuration (= 1.123) but 1.156 is installed
 libpurple-bin : Depends: libpurple0 but it is not installed
 systemd : Depends: libsystemd0 (= 215-17+deb8u5) but 232-8 is installed
 udev : Depends: libudev1 (= 215-17+deb8u5) but 232-8 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I get a similar error when trying to install individual packages. Here is what my sources.list looks like:

# 

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160609-14:12]/ testing contrib main non-free

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160609-14:12]/ testing contrib main non-free

deb http://debian.gtisc.gatech.edu/debian/ testing main 
deb-src http://debian.gtisc.gatech.edu/debian/ testing main 

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

# testing-updates, previously known as 'volatile'
deb http://debian.gtisc.gatech.edu/debian/ testing-updates main contrib non-free
deb-src http://debian.gtisc.gatech.edu/debian/ testing-updates main contrib non-free

So, any suggestions on how to resolve this problem?

0

Debian testing is more popular with desktop users than Debian stable

I strongly disagree with this statement.

Debian testing & unstable are development branches and are not intended for normal usage, those versions are supposed to be used for bug-hunting and, as such, cannot be expected to be completely functional on a consistent basis.

Testing and unstable are not simply "Debian stable with newer packages", the paradigm is completely different and almost diametrically opposed to that used for the stable release.

If newer package versions are required, I would recommend using the jessie-backports repositories instead [1] or waiting until Debian 9.0 is released later in the year.

[1] https://backports.debian.org/

  • Thanks for the advice. I've tried changing 'testing' in my sources.list file back to 'jessie', but it seems that going back to jessie isn't that simple. How would I go about going back to stable without completely reinstalling? – Ryan McCleary Feb 5 '17 at 21:24
  • You can't go back, you should re-install instead. EDIT: or restore your backup. – Head_on_a_Stick Feb 5 '17 at 21:33
0

apt is not designed to downgrade a Distro-version. But maybe you can do it with apt-pinning.

Generate the file

/etc/apt/preferences.d/jessie-preferences

    Package: *
Pin: release o=Debian                                                  

Pin-Priority: 1001

the last command is a simulation.

apt update && apt --dry-run dist-upgrade When no Package-conflicts you can do it without --dry-run. It can work but it can also not work. Backup first.

too fast. After that remove the file.

  • apt can downgrade packages, it's the packages themselves which aren't designed to be downgraded. It may work, but there's no requirement for downgrades to be supported. So you can force downgrades with apt, but you might break your system... – Stephen Kitt Feb 6 '17 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.