0

I update my Arch-Linux system using yaourt. When updating packages from the AUR, yaourt doesn't allow itself to be run as root, so it instead asks for sudo privileges every time it installs / updates a package. I don't mind this too much, however if I don't notice my terminal asking for my sudo password, it might be a few minutes until I check and notice it. When this happens, even though I type my password in correctly, I get an authentication error message, and it asks for my password again a few times, even though it still wouldn't work.

So my question is: how can I disable the sudo password prompt from timing out?

1

Have a look at the sudoers manual, and search for the password_timeout and timestamp_timeout settings.

The default seems to be 15 minutes for timestamp_timeout and 0 (no timeout) for password_timeout, but your system probably has another password_timeout.

  • Adding this to my sudoers file fixed the problem. Thank you! Defaults passwd_timeout = 0 – rusins Feb 8 '17 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.