0

I just installed Linux Mint 18.1 (Xfce) on my Lenovo Yoga 13. As with the 17 version my wifi card (realtek rtl8723au) did not work after installation and I tried to solve it as I did for the previous installation

sudo apt-get update    
sudo apt-get install build-essential linux-headers-generic linux-headers-`uname -r`

sudo apt-get install git    #git
cd /tmp
mkdir wifi    #Wifi
git clone https://github.com/lwfinger/rtl8723au.git wifi    #driver
cd wifi
make && sudo make install
cd ..    #/tmp
sudo rm -r wifi

This worked perfectly in the previous case but not now.

Edit I have found that if I disable and re-enable the wifi in the network menu it connects for about 1 minute but then stops working again and can not find any networks.

These are the responses to lsusb and rfkill list all:

lsusb
Bus 002 Device 004: ID 04f2:b322 Chicony Electronics Co., Ltd 
Bus 002 Device 003: ID 2047:0855 Texas Instruments Invensense Embedded MotionApp HID Sensor
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 04f3:000a Elan Microelectronics Corp. Touchscreen
Bus 001 Device 004: ID 0bda:1724 Realtek Semiconductor Corp. RTL8723AU 802.11n WLAN Adapter
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 0bc2:ab24 Seagate RSS LLC 
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

.

rfkill list all
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

I have searched for tutorials to help me but I can not find one that works. How can I solve this?

  • 1
    Please edit the question to include results for lsusb; rfkill list all Thanks – Jeremy31 Feb 5 '17 at 20:16
0

I had the very same issue and although the following post was specifically about rtl8723be it was helpful:

https://techcatalystblog.wordpress.com/2016/07/12/rtl8723be-wifi-fix-for-linux/

Specifically, the info on antenna selection.

In my case, I used the Realtek drivers included in kernel 4.4.0-104 which cover all 8xxxu versions See here: /lib/modules/4.4.0.104-generic/kernel/drivers/net/wireless/realtek

# load modules
$sudo modprobe -rv rtl8xxxu
# select the alternate antenna
$sudo modprobe -v rtl8xxxu ant_sel=2

To make the change permanent, modify /etc/modprobe.d/iwlwifi.conf to include these options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.