0

I'm using apache 2.2.15 in production now I want to add some modules like :

mod_access_compat.so
mod_allowmethods.so

I installed apache with yum in CentOS 6 and I can't switch to any other version.

  • You install it and enable automatically.You can configure it. – supriady Feb 5 '17 at 14:36
  • @supirady please can you explain more ! – BOUKANDOURA Mhamed Feb 5 '17 at 14:40
  • When you install it from yum or rpm packages.That 2 modules will add to apache.I didnt use that 2 modules. I just answered your question.When you compile that 2 modules from source code.You should add it manually to apache. – supriady Feb 5 '17 at 14:43
  • This is the problem, i cant find those modules in "apache_dir/modules" – BOUKANDOURA Mhamed Feb 5 '17 at 14:46
  • How did you install that 2 modules? You can find that 2 modules module-name.so when you installed it successfully.By Default Apache on Centos 6 didnt have that 2 modules. – supriady Feb 5 '17 at 14:49
2

You say you're using apache 2.2.15 in production, and you can't switch to any other version.

That means you're out of luck, as mod_allowmethods is only included in Apache 2.4.x.

So you need to either:

  • Compile them from source.
  • Upgraded your apache version/installation to something more recent.
  • Hope somebody has backported them.
  • thanks for the reply, so i did compile from the source the same version 2.2.15 with ./configure --enable-layout=admin --enable-mpms-shared=all --enable-modules=all --enable-mods-shared=all but when check the modules i can't find bothe allowmethods and access_compat ! – BOUKANDOURA Mhamed Feb 6 '17 at 10:58
  • While I'd love to help it would be easier if you showed error messages, or failure-logs. When running "./configure", then make, did you see generated .so files with the right filename? Do you understand that compiling from source will cause you failures in the future - because you'll have binaries installed by the system-package-manager and your source tree? – user28151 Feb 7 '17 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.