2

My problem is that my internet connection works great when I start up my computer, but if I don't use the internet for a while it stops working. It says I still have a connection but anything that uses the internet doesn't work anymore. When I restart my computer it works again, but again if I leave it for a while it quits. I am running Linux Mint 18. Does any one know what to do to fix this. Changing the configuration file so it doesn't have power saving options enabled or restarting the network manager doesn't work.

closed as too broad by Rui F Ribeiro, G-Man, Kusalananda, GAD3R, Tomasz Feb 5 '17 at 15:58

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Sounds like your card (wifi probably) goes to sleep and enables power saving options. Identify your card and search for disabling power saving options for your card. – George Vasiliou Feb 4 '17 at 23:53
  • sudo systemctl restart network-manager.service does what? solves the problem in current session? – LinuxSecurityFreak Feb 5 '17 at 5:05
  • Please explain what is to broad about the question so I can edit it to match criteria. @GAD3R – Nathan Hill Feb 21 '17 at 19:43
0

Due to a change in Ubuntu's network manager, wifi power management is now enabled by default for most wireless cards. In order to disable power management open a terminal window and enter

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Reboot

Not the answer you're looking for? Browse other questions tagged or ask your own question.