0

I have a small local server serving a website. The website works fine 24/7, but after a few hours I can no longer connect to the server over SSH. If I try I just get a blank screen, and eventually:

ssh: connect to host 192.168.0.188 port 22: Operation timed out

Meanwhile the website continues to work fine. I've tried to check the logs but can't seem to find anything. What could be wrong?

netstat -plunt | grep ssh shows

0 0.0.0.0:22 0.0.0.0:* listen 1417 sshd 0 :::22 :::* listen 1417/sshd

Ssh localhost also allows me to log in

  • Welcome to U&L. If you want to get some help please provide some quantitative information instead of qualitative description. "craps out" means what, exactly? What happens (or doesn't happen)? What error messages do you get - on the client and the server? What log files did you look at? For ssh on Debian I'd start with /var/log/auth.log. Can you leave an ssh connection open during the time it starts to go wrong so that you don't need to log in? – roaima Feb 4 '17 at 22:44
  • Nothing happens. I try to log into ssh and nothing it just goes blank. No error messages on the server. I looked in auth.log there isnt anything in there just the successful ssh connections. So i think ive provided as much information as i have there isnt anything else. Please remove the hold. – Learner Feb 4 '17 at 23:04
0

Curious that it's not reporting anything in a log file. My inital thought is a possible performance problem (memory, cpu, network).

You mention a local server, so I'm assuming you're logging in locally to look at the problem? If so, is sshd still running? If it is, have you tried running a strace on it?

What version of sshd and openssl are you using? Perhaps a bug or someone is crashing your sshd.

  • I tried running strace but it just output all of the program and i dont really know how to further debug it. In terms of sshd i have version 6.7p1 debian-5+deb8u3 openssl 1.0.1t. If i ping it i get request timeout. But when i use the web interface there arent any issues. its weird – Learner Feb 4 '17 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.