2

UPDATED: I have Linux Mint 18.1 running on an HP laptop.

VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display...

I can install the drivers from https://01.org but the update tool fails 'make' (but ./configure runs clean) with error:

make[3]: Leaving directory '/home/Documents/video_driver/xf86-video-intel-2.99.917/src/sna'
Making all in uxa
make[3]: Entering directory '/home/Documents/video_driver/xf86-video-intel-2.99.917/src/uxa'
  CC       intel_display.lo
  CC       intel_driver.lo
intel_driver.c: In function 'redisplay_dirty':
intel_driver.c:645:2: error: too many arguments to function 'PixmapSyncDirtyHelper'
  PixmapSyncDirtyHelper(dirty, &pixregion);
  ^
In file included from /usr/include/xorg/gc.h:54:0,
                 from /usr/include/xorg/dix.h:51,
                 from /usr/include/xorg/privates.h:151,
                 from /usr/include/xorg/cursor.h:53,
                 from /usr/include/xorg/scrnintstr.h:53,
                 from /usr/include/xorg/xf86str.h:39,
                 from /usr/include/xorg/xf86.h:44,
                 from intel_driver.c:49:
/usr/include/xorg/pixmap.h:131:1: note: declared here
 PixmapSyncDirtyHelper(PixmapDirtyUpdatePtr dirty);
 ^
Makefile:524: recipe for target 'intel_driver.lo' failed
make[3]: *** [intel_driver.lo] Error 1
make[3]: Leaving directory '/home/Documents/video_driver/xf86-video-intel-2.99.917/src/uxa'
Makefile:598: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/Documents/video_driver/xf86-video-intel-2.99.917/src'
Makefile:468: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/Documents/video_driver/xf86-video-intel-2.99.917'
Makefile:399: recipe for target 'all' failed
make: *** [all] Error 2

error.

I did find this for ATI (not intel) https://lists.x.org/archives/xorg-driver-ati/2015-July/027750.html It failed. Though I knew it was gong to fail before trying, none of the target files existed. I couldn't find one for Intel specific.

None of the driver software leaves a trace of driver files on my system either (i.e. .ko driver file), to perform a manual install (I know how to use modprobe).

Where can I get the .ko files so that I can do a manual install and skip all the install scripts?

Or and install script that works as a choice #2

2

Intel does not offer a proprietary driver, the packages on 01.org just exist to update the open-source drivers for select distributions(Fedora and Ubuntu). If you want a newer driver, you just need to update your kernel(for the driver) and mesa(for the userspace that goes with it).

  • The Linux standard drivers are very possibly causing my laptop to hang 10 times per day (while in x11 only, total freeze). I am in the kernel trying to set up debugging because logs are clean. But step #1 is always to try the proprietary video drivers first. If that site does not have them, where can I get them? – nix Feb 4 '17 at 16:36
  • Is there a link to the kernel settings that need to be initialized? – nix Feb 4 '17 at 16:47
  • 1
    There are no "proprietary" Intel drivers, Intel only provides the free software drivers which are included in the kernel (or as updates on 01.org for systems with older kernels). To get the latest Intel drivers, install the latest kernel and the latest Mesa, and remove the X.org Intel driver (X.org works best with the kernel's mode-setting support and no specific driver in X). – Stephen Kitt Feb 4 '17 at 16:47
  • My system is completely up to date. That's not going to fix my issue I'm afraid.... phuck me... – nix Feb 4 '17 at 16:52
0

Even using LTS kernels and the most recent ones, my Xubuntu system was still randomly hanging and only a hard system reset required. After my root file system was corrupted twice because of this ungraceful shutdown method I started looking for solutions.

Here's what worked for me: I added the following section to /usr/share/X11/xorg.conf.d/20-intel.conf

Section "Device"
Identifier "Card0"
Driver "Intel"
Option "AccelMethod" "uxa"
EndSection 

For some reason the default sna method causes random system hangs from which there is option except the hard system power off. After changing to uxa I haven't had a single system freeze.

I tried asking on forums but as usual, the people there just flamed me so I do not think there will be a solution anytime soon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.