0

I have a Lenovo T420s with displayport and discrete graphics chip (NVidia GF119). I installed CentOS 7 with pulseaudio and all works great - for a while. Then audio stops.

pavucontrol shows the GF119 connected to my monitor, and the graphical slider in pavucontrol moves with the audio being sent...but no sound is heard. I have to power cycle the laptop to restore audio to the displayport again.

On startup the syslog shows:

[    3.357359] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14
[    3.357429] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input15
[    3.357486] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input16
[   14.475665] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 8
[   14.487664] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 0

but there are no HDMI related message after bootup.

I'm not sure how begin to diagnose this...is it pulseaudio issue? displayport? Nvidia? CentOS? I tried using 'speaker-test' with every device and internal laptop speakers work, but no sounds from the monitor connected by displayport.

Can someone offer steps to track down the cause? (I found a similar issue enter link description here but not sure if relevant)


UPDATE: After the problem appeared I killed pulseaudio and ran speaker-test direct to my 3 HDMI devices, and no audio heard. So I assume not a pulseaudio issue. I tried to compare pre- and post-failure of various sound settings, and noticed that proc/sound/card0/codec0 my "stream=0" changes to "stream=5" in case that means anything??

Node 0x08 [Audio Output] wcaps 0x62b1: 8-Channels Digital Stripe
  Converter: stream=5, channel=0
  Digital: Enabled GenLevel
  Digital category: 0x2
  IEC Coding Type: 0x0
  PCM:
    rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
    bits [0xe]: 16 20 24
    formats [0x5]: PCM AC3
  Unsolicited: tag=00, enabled=0
  • For "stops working after some time" I'd suspect some driver issue (but who knows). First step is to take Pulseaudio out of the equation and test if it's still a problem: Stop Pulseaudio, use aplay -l to list devices, test by playing wav files etc. with aplay or speaker-test (with Pulseaudio stopped, will go through ALSA directly). Also, look in dmesg / syslog for which kernel modules is responsible for your audio, and any suspicious messages wrt. sound. – dirkt Feb 4 '17 at 13:50
  • Since I tried speaker test using the hwplug devices, does that mean I already bypassed pulse? Would that mean alsa/nvidia/sound? – TSG Feb 4 '17 at 16:55
  • There can be different audio streams (collections of a number of channels) sent to the sound codec at the same time, "stream=x" is the number of the currently used one. It might very well be a bug, if it's sending stream 0, but the converter (DAC) thinks it's stream 5. (1) Upgrade to newest kernel with newest sound drivers. (2) If that doesn't fix the problem, file a bug for the Intel HDA sound driver in the kernel. – dirkt Feb 5 '17 at 5:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.