0

I had tried fdisk command to delete it and dd command to overwrite that 2 partitions but that 2 partitions still exist. Any suggestion to delete that 2 partitions on my Toshiba USB flash disk 16 GB? It's hardware problem or not.Because it took time to mount it

6
  • 3
    Can you share more info regarding the actions that you took? Also, when you plug the usb, what do you get? Is it mounted automatically and you see that it has two partitions? Also for a more gui friendly solution, have you tried to delete both partitions and create a new one, using the gparted tool? Commented Feb 3, 2017 at 8:20
  • I mounted automatically.I cant use gparted. Because it took time when I tried to delete it.I used iso file to overwrite that 2 partitions.After I deleted it and wrote it.But that 2 partitions still exist.I cant create new partition.That's a problem.
    – supriady
    Commented Feb 3, 2017 at 8:28
  • You can also try with cfdisk which is cli program with a simple gui and you can easily use it. Try to remove both partitions and then create a new one with the desired filesytem. Commented Feb 3, 2017 at 8:35
  • Where can I find cfdisk when I used SL 7.2 64 bit?Any different between fdisk and cfdisk?
    – supriady
    Commented Feb 3, 2017 at 8:56
  • 1
    This likely won't solve the problem, but always umount all parititions of some device before you change the paritition table.
    – dirkt
    Commented Feb 3, 2017 at 9:16

1 Answer 1

2

I usually wipe USB block devices like this:

Using lsblk -f, determine where in the device tree the device is and see if any parts of it are mounted anywhere.

Use umount -l /path/to/partition to unmount any partitions that are mounted on the device, if any.

Use dd if=/dev/zero of=/dev/sdX bs=8M && sync to wipe the device entirely (where 'X' is the location of the block device). Be very careful not to accidentally run this on the main drive on your computer!

Unplug the device, then plug it back in to clear any lingering mtab information.

Check the device again with lsblk -f to make sure it's empty, then rebuild the partitions or restore an image file onto the device to get it back to working condition.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .