0

I have one server, which I did not use for one month, literally shut down.

The server is running Debian 9.0. I upgraded it from Jessie about two months ago to testing repository.

Yesterday I needed it, so I turned it on and upgraded all packages for security reasons.

Before this upgrade: GRUB booted automatically the only OS on this server.

After this upgrade: I must press Enter for it to do so. Therefore I must have keyboard plugged in etc. I am sure you understand the inconvenience.

Also I noticed changed background both on the login screen, and the desktop.

As far as I know, this file:

/etc/default/grub

is responsible for GRUB's behavior, so I copy-paste it first:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I did not do any other change. I am unsure whether it upgraded from Stretch to Sid or whatever the naming is. I am also confused as to what could cause this kind of seemingly negligible problem, but I sincerely hope there are folks who understand Debian better than me.

If you need any information I will deliver it on a timely fashion.

EDIT1:

uname -a

output

Linux backup-server 4.9.0-1-amd64 #1 SMP Debian 4.9.2-2 (2017-01-12) x86_64 GNU/Linux

and

cat /etc/apt/sources.list

output

deb http://ftp.sh.cvut.cz/debian/ testing main contrib non-free
deb-src http://ftp.sh.cvut.cz/debian/ testing main contrib non-free

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free
0

Today I did a regular maintenance, one of which is to do a full upgrade:

sudo apt-get dist-upgrade

Among those upgraded, there was a new kernel, and also new GRUB packages installed.

Problem got solved by this. Booting automatically again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.