3

I am trying to install CentOS 7.2 on a ppc64le machine. I downloaded the iso from the CentOS site used the dd command to make a bootable USB.

When selecting the install option from the boot menu I get lots of dracut timeouts:

[  197.747052] dracut-initqueue[1412]: Warning: dracut-initqueue timeout - starting timeout scripts

and then it drops to a dracut shell:

[FAILED] Failed to start Switch Root.
See 'systemctl status initrd-switch-root.service' for details.
Warning: /dev/root does not exist
Generating "/run/initramfs/rdsosreport.txt"

Entering emergency mode. Exit the shell to continue.
Type "journalctl" to view system logs.
You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot
after mounting them and attach it to a bug report.

I have tried the Minimal install, Full install and Net install isos and they all give me the same error.

5

After reading through the RHEL documentation (see Specifying the Installation Source), I managed to get the installer running by editing the boot arguments.

Before selecting the install option, press 'e' and add inst.stage2=hd:LABEL=CentOS_7_ppc64le:/ for CentOS and inst.stage2=hd:LABEL=RHEL-7.3\x20Server.ppc64le:/ for RHEL to the boot arguments.

The stage2 argument should point to where the installation runtime image is located on the USB. I'm not sure why this modification is required, perhaps they specified the incorrect default LABEL.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.