11

I've tried to use the cpupower command on my Ubuntu machine and got this error message

WARNING: cpupower not found for kernel 4.6.0

  You may need to install the following packages for this specific kernel:
    linux-tools-4.6.0-4.6.0
    linux-cloud-tools-4.6.0-4.6.0

I've tried to install linux-tools for kernel 4.6.0 using apt-get but it seems that it only supports version up to 4.4.0-59.

Is there any way to run cpupower on my Ubuntu machine properly?

5
  • How did you install your 4.6 kernel? Commented Feb 2, 2017 at 7:32
  • I just downloaded the ubuntu 14.04 from the legitimate repo.
    – ruach
    Commented Feb 2, 2017 at 7:33
  • Not very helpful, but cpupower works for me in 16.10 (kernel 4.8*)
    – Zanna
    Commented Feb 2, 2017 at 7:46
  • Hmm.. Did you get the cpupower with the apt-get command? or is it pre-installed when you install the ubuntu?
    – ruach
    Commented Feb 2, 2017 at 7:47
  • 1
    It's provided by the package linux-tools-common which was in the installation, not installed later by me through APT
    – Zanna
    Commented Feb 2, 2017 at 8:22

3 Answers 3

8

this must work with any version:

$ sudo apt-get install -y linux-tools-$(uname -r)
1

For MX Linux its:

sudo apt-get install linux-cpupower

Also in MX linux, you can open the MX Package Installer and search for 'cpupower' under the Full App Catalog

For Zorin 15.2 its:

sudo apt-get install -y linux-tools-common linux-tools-$(uname -r)

You can also go to Synaptic and search for linux-tools-common. You can also search for linux-tools- and the output of uname-r. ex. linux-tools-5.3.0-42-generic

0

Some years later...

I had the same problem with cpupower in Ubuntu 20.04.4 LTS.

I tried installing linux-tools-common, linux-tools-generic, and linux-tools-oem to no avail. I always got the message

cpupower not found for kernel 5.14.0-1033

I needed linux-tools specifically for this kernel. Sadly, in the synaptic package manager there was no trace of such kernel. And even the command sudo apt-get install -y linux-tools-$(uname -r) gave me the message

Unable to locate package linux-tools-5.14.0-1033-oem

Solution:

  1. Download the .deb package at the official site for Ubuntu Package Search searching for linux-tools-5.14.0-1033-oem
  2. Install the package easily on command line with sudo dpkg -i mypackage.deb (watch out that you have already all dependencies installed ;))

In my case I had to install two packages: first, the dependency linux-oem-5.14-tools-5.14.0-1033_5.14.0-1033.36_amd64.deb and, then, the main package linux-tools-5.14.0-1033-oem_5.14.0-1033.36_amd64.deb

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .