0

So i have linux mint 18.1 installed and i have a Canon MF 4370dn printer/scanner, i got the printer side working using the drivers from Canon's site, but the scanner side is still not working.

scanimage -L recognizes the scanner:

device `pixma:04A926EC_SJF890301025D' is a CANON Canon imageCLASS MF4360 multi-function peripheral

scanimage -V:

scanimage (sane-backends) 1.0.25git; backend version 1.0.25

scanimage -T fails:

$ sudo scanimage -T
scanimage: scanning image of size 640x877 pixels at 24 bits/pixel
scanimage: acquiring RGB frame, 8 bits/sample
scanimage: reading one scanline, 1920 bytes...  FAIL Error: Error during device I/O
2

Canon MF4370dn's specifications page shows:

OS Compatibility Windows® 7, Windows Server® 2008, Windows Vista®, Windows Server 2003, Windows XP/2000, Mac® OS X 10.3.9 & up, Linux (print only)

  • Ok.... Could i run the scanner in a vm or with wine? – Jojo01 Feb 2 '17 at 3:55
  • Although the printer is listed as a sane compatible device: sane-project.org/sane-mfgs.html – Jojo01 Feb 2 '17 at 4:01
  • I really need the scanner to work... – Jojo01 Feb 2 '17 at 4:03
1

This scanner works over USB out of box with xsane 0.999 on mint 18.1. I am transitioning from openSuse 13.1 where it also worked, just tried it on 18.1.

I don't remember the network scanning working tho.

And I'm certain it would work in a VM (although haven't tried).

HTH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.