1

I am running Centos 6.8 and would like to install a higher version of Samba. I am already running Samba, but I think I need some of the newer features (like Spotlight support).

Normally I try to install software via yum, and, if possible I would like to do the same for Samba.

  • is there a Yum Repo I can use to do this?
  • if not, would installing from RPM or Source still use my existing configuration?

I am aware of Samba+, but it’s very expensive for my own needs.

4
  • what is your current samba version ? Feb 2, 2017 at 5:33
  • @AliGolestan Version 3.6.23-36.el6_8
    – Manngo
    Feb 2, 2017 at 5:34
  • have you tried yum update ? Feb 2, 2017 at 5:35
  • Yup. No Packages marked for Update
    – Manngo
    Feb 2, 2017 at 5:36

2 Answers 2

0

you can directly download any version of Samba from the official site . https://download.samba.org/pub/samba/stable/

you may add EPEL repository too, which provides 100% high quality add-on software packages for Linux distributions. Use below links to add EPEL repository based on your Centos OS versions:

  • CentOS 6 32-Bit:

#wget http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm

#rpm -ivh epel-release-6-8.noarch.rpm

  • CentOS 6 64-Bit:

#wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm

# rpm -ivh epel-release-6-8.noarch.rpm

keep me updated about the result please.

9
  • I have added the repo and tried yum update samba again, but there are still no packages marked for Update.
    – Manngo
    Feb 2, 2017 at 6:14
  • please try downloading from official site and see if it installs the latest package Feb 2, 2017 at 6:15
  • From source? I was hoping to do that via yum or an rpm. In the past I have had issues installing from source while there is an existing yum installation. Would my current configuration still work?
    – Manngo
    Feb 2, 2017 at 6:18
  • there is a chance if you install from source your current samba configuration get replaced. please copy a backup of your current samba configuration then install from source Feb 2, 2017 at 6:23
  • It is never recommended to do a compilation of any software on a RHEL system. This is prone to error, mistakes, and possible OS degradation. if you truly need newer packages, please download the source RPM and rebuild it with the version you need using mock.
    – Sokel
    Feb 2, 2017 at 7:11
0

CentOS 6.x provides samba4 packages with (currently, as of the time of writing this) version 4.2.10:

# yum info samba4 Loaded plugins: fastestmirror, priorities, versionlock Loading mirror speeds from cached hostfile 2111 packages excluded due to repository priority protections Available Packages Name : samba4 Arch : x86_64 Version : 4.2.10 Release : 15.el6 Size : 428 k Repo : centos6 Summary : Server and Client software to interoperate with Windows machines URL : http://www.samba.org/ License : GPLv3+ and LGPLv3+ Description : Samba is the standard Windows interoperability suite of programs for Linux and Unix.

Is 4.2 new enough for your needs? It's certainly a lot newer than 3.6.x as the default samba version which comes with CentOS 6... :)

You'll probably also want samba4-winbind and some more, but these may be installed as dependencies of this package anyhow. Check the output of yum search samba4 for other related packages!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .