1

I've a Debian in my computer and now I want to add a Gentoo distro. I've installed Gentoo by terminal in Debian and chrooted to Gentoo in order to emerge all packages.

Now, I added Gentoo to Grub (installed on Debian) and for that I used the command:

root@reborn:/home/jota# grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Encontrada imagen de linux: /boot/vmlinuz-3.16.0-4-amd64
Encontrada imagen de memoria inicial: /boot/initrd.img-3.16.0-4-amd64
Encontrado Gentoo Base System release 2.3 en /dev/sda3
hecho
root@reborn:/home/jota#

So it works ok. When I reboot I have the new entry of Gentoo but when is booting the system halts with kernel panic error

Kernel panic - not synching:VFS:Unable to mount root fs on unknown-block(0,0)

The part of grub.cfg seems ok,

menuentry 'Gentoo Base System release 2.3 (en /dev/sda3)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-f40f428c-f76d-489f-9d97-a259f34ed457' {
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos3'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3  f40f428c-f76d-489f-9d97-a259f34ed457
    else
      search --no-floppy --fs-uuid --set=root f40f428c-f76d-489f-9d97-a259f34ed457
    fi
    linux /boot/vmlinuz-4.4.39-gentoo root=/dev/sda3 ro
}

fdisk output is:

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sda1            2048  97656831  97654784 46,6G 83 Linux
/dev/sda2        97656832 116088831  18432000  8,8G 82 Linux swap / Solaris
/dev/sda3  *    116088832 218488831 102400000 48,8G 83 Linux

Where sda1 is Debian /, sda2 is swap for both Debian and Gentoo, and sda3 is Gentoo /

I've tried to change the boot flag trough sda1 and sda3 with no changes.

And the fstab file of Gentoo is:

/dev/sda3       /       ext4        errors=remount-ro   0 1
/dev/sda2       none        swap        sw          0 0

Edit: As mentioned in comments, Gentoo doesn't generate initrd.img file, I've never needed it before.

root@reborn:/boot# ls /boot/
config-3.16.0-4-amd64  grub  initrd.img-3.16.0-4-amd64  System.map-3.16.0-4-amd64  vmlinuz-3.16.0-4-amd64
root@reborn:/boot# ls /mnt/gentoo/boot/
config-4.4.39-gentoo  config-4.4.39-gentoo.old  grub  System.map-4.4.39-gentoo  System.map-4.4.39-gentoo.old  vmlinuz-4.4.39-gentoo  vmlinuz-4.4.39-gentoo.old
root@reborn:/boot# 
  • Your grub.cfg menuentry is missing the initrd /initrd.img-3.16.0-4-amd64 (or similar) line. Not sure why though considering grub-mkconfig clearly found it (from the messages it generated) – derobert Feb 1 '17 at 18:17
  • if Gentoo isn't using initramfs, then are you sure you built the correct modules in to the kernel? Check your boot messages to make sure that sda is actually being discovered. – derobert Feb 1 '17 at 22:29
1

It was kernel driver problem. Need to add a driver for PATA controller.

CONFIG_PATA_ATIIXP=y

I found it by lshw command

*-ide
     description: IDE interface
     product: SB7x0/SB8x0/SB9x0 IDE Controller
     vendor: Advanced Micro Devices, Inc. [AMD/ATI]
     physical id: 14.1
     bus info: pci@0000:00:14.1
     version: 40
     width: 32 bits
     clock: 66MHz
     capabilities: ide bus_master
     configuration: driver=**pata_atiixp** latency=32 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.