1

My plasma desktop environment worked very well before I installed kdm display manager.But after I installed the kdm and reboot my laptop, Gentoo booted into a black screen with a white checkbox, which was saying

  Could not start kdeinit5, Check your installation.

Then I clicked the okay button. It dropped down into the tty with some error messages.

  xauth: file /root/.serverauth.8002 does not exist

  X.Org X Server 1.18.4
  Release Date: 2016-7-19
  X Protocol Version 11: Revision 0
  Build Operatin System: Linux 4.4.39-gentoo #1 SMP Fri Jan 13 20:24:54 CST 2017 x86_64
  Kernel command line: BOOT_IMAGE=/boot/kernel-genkernel-x86_64-4.4.39-gentoo root=/dev/sda2 rootfstype=ext4 
  Build Date: 13 January 2017 11:03:46PM

  Current version of pixman: 0.34.0
  Before reporting problems., check http://wiki.x.org
  to make sure that you have the latest version.

  (==) Log File: "/var/log/Xorg.0.log", Time: Sat Jan 20 21:12:01 2017 
  (==) Using config directory "/etc/X11/xorg.conf.d"
  (==) Using system config directory "/usr/share/X11/xorg.conf.d"
  The application failed to start because it could not find not find or load the Qt platform plugin "xcd" in ""

  Available platform plugins are: wayland-org.kde.kwin.qpa, minimal, offscreen, wayland, xcb.
  Reinstalling the application may finx this problem.
  startkde: Starting up...
  /usr/bin/kdeinit5: relocation error: /usr/lib64/libQt5Gui.so.5: symbol _Z10qAllocMoreii, version Qt_5 not defined in file libQt5Core.so.5 with link time reference.
  startkde: Could not start kdeinit5. Check your installation.
  xinit: connection to X server lost.
  waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

However, it works pretty well before I installed kdm. I don't know why it crashed after I had installed kdm.

I also had found some advice from the Internet and tried. But those all didn't work. Can anyone give some solutions or some clues? My environment is:

  • plasma version is: plasma-5.26.0

  • kdm version is: kde-plasma/kdm-4.11.22

  • kernel version is 4.4.39

  • Looks like some kind of Qt version mismatch. Did kdm install another version of Qt? – StefanR Feb 1 '17 at 10:09
  • @StefanR I don't know exactly. how to check it out? – ResRelentelss Feb 1 '17 at 10:31
  • @StefanR Maybe it is, because I have noticed that there two versions of qt in my /usr/lib64 directory, one is qt4 , another is qt5 , but can you tell me how to resolve this problem and make my kde work again? thanks a lot. – ResRelentelss Feb 1 '17 at 13:27
  • It's really long time since I have used gentoo.. But the Qt version 5 is the one you want to be using here. So you should check that did you install correct version of KDM. How did you install it, what command did you use? I would remove that, because it is probably older than rest of the KDE you have installed. – StefanR Feb 1 '17 at 13:43
  • But the newest version of kdm in my portage is 4.11.22, how can I get the newer one? And I have tried to uninstall the kdm and use the sddm and xdm, this error still be there. – ResRelentelss Feb 2 '17 at 3:11
1

  First, thanks to @StefanR for saving my lots of time!
  Just as methioned by @StefanR above, this problem is caused by Qt version mismatched. After I removed the kdm by emerge -C kdm and updated some stuff referred qt by emerge -av @qt5-essentials @qt5-addons, my kde desktop environment works again as a charm.

Must be mentioned

  if you portage claimed that There are no sets to satisfy 'qt5-essentials' or There are no sets to satisfy '@qt5-addons', you maybe lack some layers in your system, solved by using following command:

  emerge layman
  layman -S
  layman -a qt
  layman -a gentoo 
  emerge --ask @qt5-essentials @qt5-addons

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.