0

I am having difficulty with my Fedora 25 installation. I have been using the default gnome for a while, but wanted to try a different desktop environment. I installed Enlightenment using dnf install enlightenment connman. This worked, and enlightenment worked but the networking didn't. I wasn't as enamored with enlightenment as I thought I would be so I booted back into gnome and deleted enlightenment but I also had networking issues in gnome. The little wifi icon now had a question mark. It says it's connected to my network when click on it, and I can also connect to 192.168.1.1 but I can't actually get to the Internet. The NetworkManager service is enabled and running rfkill shows nothing is blocked and nmcli shows me connected to my home network. But every time I open a browser i can't get to any websites and I can't ping any websites either. I have no idea why I can't get to the network even though it was working right before i installed Enlightenment. I have found almost no information on the Internet and have no idea what the actual problem is, since as far as all of the networking information shows I am connected to the my home network. I have tried rebooting, logging out and back in, powering down completely, etc. If I can't resolve this I think I'm just going to switch to the KDE variant of Fedora, although I would really rather not since I have a ton of config files and such installed and configured just the way I like.

1

I had a similar problem, and with further investigation found that I could ping to IP addresses (ping XXX.XXX.XXX.XXX) both on my local LAN and on the internet (ping 8.8.8.8). Pinging to web addresses did not work, such as ping mail.yahoo.com, indicating a problem with domain name resolution. When the uninstall of connman takes place it leaves behind symbolic links for the /etc/resolv.conf file to /var/run/connman/resolv.conf. This link needs to be replaced with the link back to the NetworkManager config files, which are in /var/run/NetworkManager/resolv.conf. The command is;

ln -sf /var/run/NetworkManager/resolv.conf /etc/resolv.conf

Once the link back to the NetworkManager file is established connections using domain names can again be established.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.