0

I use Debian Jessie on my host machine. And the same version on guest. I want to use user mode networking with qemu-kvm. I experienced no connectivity, i. e. wget www.google.com returned no connection. I am surprised, because dedian-installer can reach internet resources during installation process (i installed Debian Jessie on guest machine from netinst image).

Qemu command:

/usr/bin/kvm -monitor stdio \
             -smp 2 -cpu kvm32 -enable-kvm -m 512\
             -soundhw ac97 \
             -vga std \
             -drive file="image.qcow2",cache=writeback,aio=threads \
             -boot once=c,menu=off \
             -net nic,vlan=0 -net user,vlan=0 \
             -no-quit -name "boot"

Any ideas?

  • When you installed from netinst, did you start kvm with same parameters? – ridgy Jan 31 '17 at 19:19
  • Yes. Except boot device priority and cd-rom image. – akj Jan 31 '17 at 19:54
0

In fact the problem caused by ipv6-networking. Host system have no ipv6 access, so on the guest side i can not get access to ipv4 network by ipv6 protocols.

So i turned ipv6 support off by passing corresponding option to the kernel. I added to /etc/default/grub this line:

GRUB_CMDLINE_LINUX="ipv6.disable=1"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.