5

I am trying to enable the smooth scrolling feature in Zathura. I have the following line in my zathurarc: set smooth-scroll true, but the scrolling doesn't become smooth.

According to the documentation:

smooth-scroll

Defines if scrolling via touchpad should be smooth(only available with gtk >= 3.4).

I have gtk 3.22 installed (which is greater than 3.4, right?) as dpkg -s libgtk-3-0|grep '^Version' gives me Version: 3.22.4-1.

What do I need to do in order to enable smooth scroll? The "via touchpad" part is also suspicious, but I can't get it to work on either a touchpad, a scrollwheel or with the keyboard.

Another suspicious thing is that it does not autocomplete when I type :set sm which it does with other options.

  • can you try setting a verbose error-log level? Maybe that would give you a hint about the underlying problem. Also, have you observed problems with other applications and the scroll-speed? – ILMostro_7 Oct 3 '17 at 14:51
  • In newer releases of Zathura (0.4.3) the scrolling is now smooth by default. Still no smooth-scroll option. – Hielke Walinga Jan 10 '19 at 21:27
  • @ILMostro_7: Nope, I don't see anything suspicious with verbose logging and nope, no other applications are behaving strange. – nijoakim Jan 10 '19 at 23:00
  • @Heilke Walinga: Hmm... Strange! I am running 0.4.3 and the scrolling is not smooth. So... Is it smooth for you, you say? – nijoakim Jan 10 '19 at 23:01
  • @nijoakim Sorry to bother you, were you able to find a workaround to enable smooth scrolling in zathura ? – Atralb Jun 12 at 15:21
2

I've just updated to the latest version (zathura 0.4.4, girara 0.3.3) and I'm now getting:

warning: Unknown option: smooth-scroll

this seems to be because of a change to girara that made smooth scrolling always be turned on

looks like we can just remove this line from our config files now!

| improve this answer | |
1

I use the touchpad and had the same problem. this got it fixed though:

:set scroll-step 50

(you can fiddle with the number to see which suits you the best)

| improve this answer | |
  • 1
    Hmm... According to the man page, that should have nothing to do with smoothness, and the default value is 40; I don't see why 50 would make a difference. I have tried it anyway, but that doesn't change the smoothness. – nijoakim Jan 10 '19 at 23:03
-2

You have to put double quotes around true

set smooth-scroll "true"

From man zathurarc

   COMMANDS
   set - Changing options
   ...   
      · BOOL - A boolean value ("true" for true, "false" for false)
| improve this answer | |
  • Seems unlikely.  I did a Google search for zathurarc, and the first hit shows examples of set … true without quotes.  Can you give a reference that supports your answer?  (Please do not respond in comments; edit your answer to make it clearer and more complete.) Can anybody verify that this works? – G-Man Says 'Reinstate Monica' Mar 7 '19 at 23:41
  • Hmm... I tried it but I don't see a difference. Thanks for your answer, though, and feel free to elaborate if you think that I have misunderstood something. – nijoakim Mar 8 '19 at 21:48
  • I have edited my answer to include a reference from the man page. Also note that smooth-scroll does not enable smooth scrolling with vim-like motion keys. It only enables with trackpad. – vn-ki Mar 9 '19 at 0:19
  • This isn't true. Zathura errors when you give it a bad value, which it does not do for just writing true instead of "true". Also this doesn't work. – half-potato Jun 9 '19 at 0:03
  • @vn-ki This is wrong. The double quotes are just a convention to unambiguously tell exactly what should be actually written in the config file : what is inside the double quotes. Unfortunately it can also be ambiguous when this convention is not clearly stated beforehand in the document. – Atralb Jun 12 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.