2

Samba was running well on ubuntu server 14.04. After upgrading to 16.10 it doesn't start anymore. I've tried also to install samba on a fresh 16.10 vm and it doesn't work.

Here the service error message:

root@srvvm:~# systemctl restart smbd
Job for smbd.service failed because the control process exited with error code.
See "systemctl status smbd.service" and "journalctl -xe" for details.
root@srvvm:~# systemctl status smbd
● smbd.service - Samba SMB Daemon
   Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-01-30 17:27:42 CET; 2s ago
     Docs: man:smbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 3075 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=1/FAILURE)
 Main PID: 3075 (code=exited, status=1/FAILURE)

Jan 30 17:27:42 srvvm systemd[1]: Starting Samba SMB Daemon...
Jan 30 17:27:42 srvvm smbd[3075]: [2017/01/30 17:27:42.769054,  0] ../source3/smbd/server.c:1441(main)
Jan 30 17:27:42 srvvm smbd[3075]:   server role = 'active directory domain controller' not compatible with running smbd standalone.
Jan 30 17:27:42 srvvm smbd[3075]:   You should start 'samba' instead, and it will control starting smbd if required
Jan 30 17:27:42 srvvm systemd[1]: smbd.service: Main process exited, code=exited, status=1/FAILURE
Jan 30 17:27:42 srvvm systemd[1]: Failed to start Samba SMB Daemon.
Jan 30 17:27:42 srvvm systemd[1]: smbd.service: Unit entered failed state.
Jan 30 17:27:42 srvvm systemd[1]: smbd.service: Failed with result 'exit-code'.
  • It says "server role = 'active directory domain controller' not compatible with running smbd standalone." then to use service samba start There could also be issues with an incorrect /etc/samba/smb.conf, or missing samba/smb packages. There should be a log in /var/log/samba/log.smbd to check as well. – Blake Russo Mar 15 '17 at 5:36
  • It seems to be 16.10-specific. So I will not bother. Let's wait for 17.04 – nicolamarangoni Mar 15 '17 at 6:19
3

The issue seems to persist in 17.04 (at least for me)

This worked for me:

sudo systemctl disable nmbd
sudo systemctl disable smbd
sudo systemctl unmask samba-ad-dc
sudo systemctl enable samba-ad-dc 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.