4

This is a really specific question, I have come here before because of it but now I really think I am out of options and trying to see if anyone has experience with this specific video card.

Have tried to install the drivers for it 4 times in the past and nothing has worked. First time with the .run available in their webpage, nothing happened because an error appeared.

Then tried using nvidia-detect but it didn't detect anything. So I added the non-free path to download nvidia-driver, nvidia-smi and nvidia-xconfig packages. The first time I ran them only having installed bumblebee but not bumblebee-nvidia so system wasn't bootable after restarting, had to purge everything of nvidia's and restore /etc/X11/xorg.conf to blank (original state), filed a bug report as someone in here recommended and they told me I needed bumblebee-nvidia for it to work. Downloaded bumblebee-nvidia, downloaded all those packages again and the system wouldn't boot after restarting, again.

Then tried again with the package from NVIDIA's webpage, this time without a graphics interface since it required that, and system crashed again.

**For all those 3 times that the system crashed I had to purge everything nvidia related and restore to blank the xorg.conf file and then type startx to have graphical interface again.

Next I tried what Debian's official page says, basically get things from backports, followed the steps to the line and it wouldn't boot again after restarting, purged everything I installed and everything nvidia related and it wouldn't boot having used the same fix I had done the previous times. A kind heart told me I had to reinstall nouveau for it work again, and it did after doing that.

Can you please help me on how I could install this specific video card's driver? I have tried everything I have found online and I don't know enough to make up solutions as I go. I can't change the brightness of the screen, can't connect extra monitors, can't use redshift (my eyes are sensitive) and can't even invert colors because of the lack of the driver.

Previously asked question here on the site

Bug Report with more information

Using Debian 8 with Gnome 3, my computer has two video cards an intel (integrated) and the NVIDIA card. Please tell me if more information is required.


Edit: to put the results of the comment

$ sudo apt-get install bbswitch-dkms intel-microcode firmware-linux-nonfree bumblebee bumblebee-nvidia primus primus-libs primus-libs:i386 linux-headers-$(uname -r) nvidia-driver

Reading package lists... Done
Building dependency tree       
Reading state information... Done
bbswitch-dkms is already the newest version.
bbswitch-dkms set to manually installed.
primus is already the newest version.
primus-libs is already the newest version.
primus-libs set to manually installed.
bumblebee is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
bumblebee-nvidia : Depends: bumblebee (= 3.2.1-7) but 3.2.1-13~bpo8+1 is to be installed
E: Unable to correct problems, you have held broken packages.

Then did sudo apt-get -f install just in case and it didn't remove or install anything.

  • Try apt-get -t jessie-backports install bumblebee-nvidia – Shadur Feb 2 '17 at 15:41
  • To bypass the error from the output? And then install again the package with the problem and do the rest of the instructions the person below said? – M.O. Feb 2 '17 at 15:43
  • 1
    That should fix the output error - you're trying to install regular bumblebee-nvidia but at some point you installed the backports version of its parent, so there's a dependency mismatch apt is choking on. – Shadur Feb 2 '17 at 15:44
  • @Shadur apt-get -t jessie-backports install bumblebee-nvidia gives the following output: The following packages have unmet dependencies: bumblebee-nvidia : Depends: glx-alternative-nvidia (>= 0.6.92) E: Unable to correct problems, you have held broken packages.. And if I try to install nvidia-driver apt-get always complains about 340 version is going to be installed and ignores jessie-backports. Could you please advise how to solve this? – Ingvord Jun 17 '17 at 5:59
0

From what I'm gathering... you have a laptop with Optimus, eg you have an nvidia and intel GPU in your laptop. Long story short, it is not easy to get both working at the same time, though bumblebee is there as a hack to get around that.

I would explain the reason why you shouldn't use the .run file from nvidia's website, but the tl;dr about it is that it actually will damage your distribution by replacing libraries and other critical components. The fact you went the route with debian's own wiki was a good start.

First you need to enable the non-free repositories in /etc/apt/sources.list and you need to enable the backports for Jessie (detailed on the same link you've provided for installing nvidia drivers for Debian). And then you can go from there:

dpkg --add-architecture i386
apt-get update
apt-get install bbswitch-dkms intel-microcode firmware-linux-nonfree bumblebee bumblebee-nvidia primus primus-libs primus-libs:i386 linux-headers-$(uname -r) nvidia-driver

And then modify /etc/bumblebee/bumblebee.conf:

KernelDriver=nvidia-current

Add yourself to the bumblebee group (required):

addgroup nazu bumblebee

You need to make a change to the GRUB command line in /etc/default/grub. Add this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet rcutree.rcu_idle_gp_delay=1"

Update grub.

update-grub

Go ahead and reboot. Most cases, it should work. In your case, I highly recommend doing a fresh installation of Debian since you've gone through multiple tries getting this to work. It's better to start fresh in this scenario.

  • Will try this later today after work. If it crashes will I have to return the bumblebee.conf and /etc/default/grub files to their original state? Or would it suffice to purge everything I installed? – M.O. Jan 30 '17 at 13:29
  • I dont think I was able to do it. I will edit the question so you can see what appeared when trying to install all the packages. – M.O. Jan 31 '17 at 2:22
  • I'm not sure, but isn't bumblebee discontinued? The last update on their webpage was 2013. bumblebee-project.org – mrtnrdl Jan 31 '17 at 7:44
0
apt-get -t jessie-backports install nvidia-driver bumblebee-nvidia primus xserver-xorg-video-nvidia nvidia-vdpau-driver nvidia-settings 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.