0

I tried ping www.google.com and ping 8.8.8.8 and access the web browser manually, resulting in "server couldn't connect".

I have 3 connections via eth0, wlan0 and wlan1(through USB) , eth0 doesn't have internet access and when I activate wlan0 or wlan1 with eth0 I dont have internet access, but when I activate only wlan0 or wlan1 I do, when I activate eth0 alone, I dont have internet access, so maybe something in eth0 configurations?

I do get an IP for eth0: ipconnection

routing

I tried disabling Wi-Fi cause i've read somewhere that wlan0/1 could be the default access and avoiding internet connection from eth0,but it didn't work also.

My /etc/network/interfaces file:

auto lo
iface lo inet loopback

My etc/NetworkManager/NetworkManager.conf file:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

0

Since you use NetworkManager, why don't you simply let NetworkManager handle all connections.

In other words, remove

auto eth0
iface eth0 inet dhcp

From your /etc/network/interfaces, and change to:

[ifupdown]
managed=false

In your /etc/NetworkManager/NetworkManager.conf

Official documentation here.

  • Tried, and restarted network manager, the problem remains. I read the documentation, and followed the instructions, didnt help too. When using ethernet and wireless together, no internet access, when using only ethernet no internet access, only wireless has internet access. Tried ping with only ethernet -> no reponse , same as ethernet with wireless no response from ping 8.8.8.8 . Any other suggestions that may help? I have changed my question accordingly. – eyal360 Jan 29 '17 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.