1

I just installed ubuntu GNOME 16.04. So far, so good.

When I run "GNOME terminal", I can do the all the things. But when asked to press "Enter", and I press the button labeled "Enter" on my kepboard near the keypad, it just does an error squirt-beep.

If I press the button above right shift (labeled <-|), it works.

How can I get the Keypad's "Enter" button to work in gnome terminal?

Thanks!

Update this fixed itself (rather I have no idea what fixed it). It was a new install: zsh, oh-my-zsh, custom profiles, software, 20 reboots, etc.

1 Answer 1

2

The two Enter keys are different. The one above the right-shift key sends a carriage-return character (which the terminal driver translates to line-feed as newline), while the other may send an escape sequence when the keypad application mode is enabled. Your instructions meant the former (unless the application uses curses, for example).

If you are trying to use a curses (or ncurses) application, you still are not guaranteed that you can use the two interchangeably. Some developers are confused by the difference, and ignore KEY_ENTER when they notice that the Enter key on the keyboard sends just a carriage return.

Along with that, some terminal descriptions have been written (no surprise) which equate kent (the terminfo name for KEY_ENTER) with carriage return or line feed. A lot of those are for obscure terminals which you probably do not use (and they represent a minority of the terminal descriptions). For xterm, kent is assigned to the escape sequence. It's been there a while (predating gnome-terminal):

# 9.11.3 (Thu Nov  9 12:14:40 EST 1995):
#       * Added kspd=\E[P, kcbt=\E[Z, to linux entry, changed kbs back to ^H.
#       * Added kent=\EOM to xterm entry.
6
  • 1
    In addition to this, the questioner might be looking for something as simple as You run printf '\e[?66l' to set DECNKM mode off or printf '\e>' (DECKPNM).
    – JdeBP
    Commented Jan 29, 2017 at 0:24
  • The terminal's initialized with that off. OP is running some half-baked application. Commented Jan 29, 2017 at 0:39
  • 1
    @ThomasDickey you don't know that and I wouldn't call gnome terminal, bash, or zsh half-baked. Commented Jan 29, 2017 at 1:15
  • If you clarify what you were running when asked to press enter, that would be helpful. Commented Jan 29, 2017 at 1:17
  • @ThomasDickey Aha! In bash, I remember this command: sudo add-apt-repository ppa:webupd8team/atom Commented Jan 29, 2017 at 1:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .