0

I have a ThinkPad X220 Tablet which I have used for five years now. The internal speakers have worked just fine until a couple of weeks ago, perhaps earlier since I do not use them often. The headphone jack works just fine, this is how I listen to music mostly.

Within pavucontrol, I can see that the headphone (“Kopfhörer”) port works fine, it says plugged in:

enter image description here

However, the speakers (“Lautsprecher”) port is not available:

enter image description here

On the Fedora developer mailing list I was asked what aplay -l would give. This is the output:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CX20590 Analog [CX20590 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Then plugging in that card number into alsamixer -c [device number] shows that the internal speaker is on zero volume:

┌────────────────────────────────────────── AlsaMixer v1.1.1 ──────────────────────────────────────────┐
│ Card: HDA Intel PCH                                                          F1:  Help               │
│ Chip: Conexant CX20590                                                       F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All                                     F6:  Select sound card  │
│ Item: Speaker [dB gain: -74.00, -74.00]                                      Esc: Exit               │
│                                                                                                      │
│                                                                                                      │
│                                                                                                      │
│    ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐                                ┌──┐              ┌──┐    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │  │              │  │    │
│    │▒▒│     │▒▒│     │  │     │▒▒│     │  │                                │▒▒│              │  │    │
│    ├──┤     ├──┤     ├──┤     └──┘     └──┘     ┌──┐     ┌──┐     ┌──┐     ├──┤   Enabled    └──┘    │
│    │OO│     │OO│     │MM│                       │MM│     │OO│     │OO│     │OO│                      │
│    └──┘     └──┘     └──┘                       └──┘     └──┘     └──┘     └──┘                      │
│    100    100<>100   0<>0   100<>100   0<>0                                 9                0<>0    │
│   Master  Headphon<Speaker >  PCM    Mic Boos  S/PDIF  S/PDIF 1 S/PDIF 2   Beep   Auto-Mut Internal  │
│                                                                                                      │
│                                                                                                      │
│                                                                                                      │
└──────────────────────────────────────────────────────────────────────────────────────────────────────┘

I then tried to increase the volume to 100%, but it does not change anything. Pulling the cable from the headphone jack will not switch the sound to the internal speakers, there will be no music.

This behavior happens when the laptop is on the docking station as well as off it. When there are no headphones plugged in, sound had gone through the built-in speakers before, on and off the dock. My home dock has speakers attached via the headphone jack, it plays music. In the office, I previously had notification sounds played by the internal speakers, so they had worked.

Since the Fedora 25 might be the issue, I have tried with Ubuntu 16.04 from a USB drive just now. There is the same issue, the same output in pavucontrol and just no sound from the speakers. Headphones work.

My current idea is that the headphone jack is physically jammed such that the hardware assumes that headphones are plugged in. Therefore the sound is routed to the headphone jack in every case. Is there something I could do to test this?

0

based on your question and comment: "headphone jack is physically jammed such that the hardware assumes that headphones are plugged in" I believe you are right. It happened to me on my desktop. I had to change the Audio Stereo Headphone Jack Socket Plug Connector.

Please see this: How do I change which audio jacks are used

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.