0

I am trying to install debian-live-8.4.0-amd64-cinnamon-desktop.iso (available from here) to my PC with windows 10 OS.

I did following steps:

  • I put it on USB
  • Booted from USB
  • I had ~105GB of free space which was automatically divided between root (/) (~100GB), swap (~5GB) and BIOSBOOT(1MB).
  • I ran Debian installation.
  • GRUB2 (It is v2 I think) installation comes up, and it says something about it did not find any other OS and if I want to install grub to the MBR. I select yes and then I select SSD with windows installation (where Debian was installed as well) /dev/sdb and GRUB seems to be installed.

But after reboot, GRUB is not showing. If I go into bios, there is no BIOS boot point for grub, just Windows Boot Manager/DVD-ROM/My nework card/(and USB/UEFI USB in case USB is connected...)

After installation SSD is divided in following order:

  • Recovery Partition (~450MB)
  • EFI System Partition (~100MB)
  • C: NTFS (~366GB)
  • BIOSBOOT (~1MB)
  • Ext4 (~94.59GB)
  • Swap (~4,04GB)

I also had my HDD (/dev/sda) and USB (/dev/sdc) connected during installation Any ideas what am I doing wrong?

  • 1
    Is your firmware set to boot in BIOS compatibility mode? Your description makes me suspect it's not, in which case GRUB should not be installed to the MBR. – Johan Myréen Jan 28 '17 at 14:42
  • I think it is, but I am not sure. What I know is - I have BIOS in my laptop (Asus G75VW). When I plugin USB with debian I have two boot points available <USBNAME> and UEFI <USBNAME>. I always boot from <USBNAME> option. I tried from UEFI too but it does not seem to work (If I have UEFI <USBNAME> and Windows Boot Manager afterwards, Windows starts loading). I have no UEFI/BIOS comp. mode option in my BIOS. – Smarty77 Jan 28 '17 at 14:59
  • Okay its looks like it is in UEFI. I am following this tutorial wiki.debian.org/GrubEFIReinstall . Using mentioned tutorial I was able to boot into my debian and command [ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD" returned "EFI boot on HDD". So for I cannot find partition with boot folder though. – Smarty77 Jan 28 '17 at 15:24
  • I guess it is on the 94 gig Ext4 partition. – Johan Myréen Jan 28 '17 at 15:27
0

Alright, partially thanks to @Johan Meyreen I think I now understand what happened and I fixed it.

Debian Jessie installation does not support UEFI boot option, and since my PC ran on UEFI, grub boot option was simply not installed.

I booted into Debian via rEFInd Boot Manager tool and then followed this simple guide to install grub into EFI partition.

Now debian boot option is available in bios and grub seems to be working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.