3

My new laptop is randomly freezing. This freezing occurs rarely - every dozen days. However once happened just after previous. The problem is that I cannot find what causes this freeze. I use this laptop for work so stability is very important.

During freeze there is noise sound from speakers (duration about one second) and malformed screen: screen after freezing

What I have checked:

  • system logs (/var/log/) - nothing found
  • memory test - OK
  • different desktop environment test - Cinnamon and KDE - both freeze
  • different graphic drivers - nvidia-367 and nvidia-375 - both freeze
  • added processor.max_cstate=1 intel_idle.max_cstate=0 in grub - it seemed to fix problem but after dosen days the freeze occured again (befor this modyfication freezing was occuring every few days or more often)

I have suspicion that problem is somehow related to using firefox, but still the program should not hang whole system.

inxi -F:

System:    Kernel: 4.4.0-21-generic x86_64 (64 bit) Desktop: KDE Plasma 5.8.5
           Distro: Linux Mint 18 Sarah
Machine:   System: LENOVO (portable) product: 80RU v: Lenovo ideapad 700-15ISK
           Mobo: LENOVO model: Lenovo ideapad 700-15ISK v: NO DPK Bios: LENOVO v: E5CN52WW date: 04/28/2016
CPU:       Quad core Intel Core i7-6700HQ (-HT-MCP-) cache: 6144 KB 
           clock speeds: max: 3500 MHz 1: 805 MHz 2: 805 MHz 3: 811 MHz 4: 841 MHz 5: 850 MHz 6: 2369 MHz
           7: 822 MHz 8: 820 MHz
Graphics:  Card-1: Intel Skylake Integrated Graphics
           Card-2: NVIDIA GM107M [GeForce GTX 950M]
           Display Server: X.Org 1.18.3 driver: nvidia Resolution: 1920x1080@60.01hz
           GLX Renderer: GeForce GTX 950M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 375.26
Audio:     Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel Sound: ALSA v: k4.4.0-21-generic
Network:   Card-1: Intel Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi
           IF: wlp2s0 state: up mac: ----------------
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp3s0 state: down mac: ----------------
Drives:    HDD Total Size: 2240.5GB (41.1% used) ID-1: /dev/sda model: ADATA_SP550NS38 size: 240.1GB
           ID-2: /dev/sdb model: ST2000LM003_HN size: 2000.4GB
Partition: ID-1: / size: 202G used: 136G (71%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 20.06GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 39.0C mobo: 37.0C gpu: 37C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 268 Uptime: 1 day Memory: 2898.7/15842.4MB Client: Shell (bash) inxi: 2.2.35 

What more should I check? Where is the problem? Is it related to Linux Mint distribution? Is it hardware problem?

EDIT:

The freezing occurs also on Windows 10 - during installation (if I leave laptop for a few minutes without touching mouse or keyboard) and after installation (without system updates). After freezing screen is malformed as on Linux.

I have updated bios to E5CN56WW version - still problem occurs.

After installation 4.9 Kernel there is no network on my Mint and other problems occur so I could not test this Kernel.

closed as off-topic by Jeff Schaller, Stephen Rauch, ilkkachu, Romeo Ninov, Archemar Dec 12 '17 at 9:45

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Stephen Rauch, ilkkachu, Romeo Ninov, Archemar
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Looks like you're dealing with this bug (as you probably already know since you've added the cstate parmeter which is the suggested workaround). Reading the comments there, I saw some people reported improvements with the latest 4.9 kernel. Have you tried upgrading your kernel? – terdon Jan 28 '17 at 13:45
  • Might sound crazy but if you have another ram make a replacement to see if goes better. – George Vasiliou Jan 28 '17 at 14:54
  • @terdon thanks, I have not seen this bug, but only some solutions with cstate (can't remember on what site). I will check 4.9 kernel. – raV720 Jan 28 '17 at 22:56
3

It came out that there was problem with ram memory and ssd drive. Both exchanged to new one under warranty and problem is solved. No freeze for three weeks with no processor flags set.

BTW there is another issue with graphic but I am going to describe it in another thread.

Not the answer you're looking for? Browse other questions tagged or ask your own question.