2

I'm trying to install Linux Mint 18 on my new Asus N552VW-FI202T.

I disabled FastBoot and SecureBoot, but when I try to install Linux, it is stuck on the logo screen.

Hardware:

Two disk drives:

  1. With Win10 installed
  2. prepared for the Linux installation

The screen attached is 4K.

I tried the installation via USB on my old lapton and it works so the problem is not the USB key.

3 Answers 3

2

after a long day i solved(i hope). for me this works:

1) download the tool RUFUS and install my iso with option -> gpt for uefi

2) follow this setup for the partition https://www.youtube.com/watch?v=lG0jWnBZhY0

3) plug my usb, but before starting linux mint live, press the key 'e', edit the line and insert the word nomodeset between the words "quiet splash"

4) now you can run your linux in recovery mode and do some basic update

5) select the nvidia card suggested(not the open source)

6)i follow this guide https://david-estevez.gitbooks.io/install-guides/content/03_nvidia_aspire_e5_573g.html and give this command

  • sudo add-apt-repository ppa:bumblebee/stable
  • sudo apt-get update
  • sudo apt-get install bumblebee bumblebee-nvidia
  • sudo usermod -a -G bumblebee $USER

And its gone for now...

0

Following this AskUbuntu Q&A ...

Rewritten from this source:

  1. Check if you have saved the changes in the BIOS, namely disabling SecureBoot and ensuring UEFI is enabled and disks are in AHCI mode.

  2. Plug in the USB and restart the machine, then press continuously Escape until it shows you the Boot Menu and then you choose your USB drive.

  3. When the Linux Mint installer asks you what to do, you have to choose do something else.

  4. Do at the end of the drive an efi partition of 535 MB, a swap, /(root) and home partition manually, all at the end of the drive ( I installed on this laptop a hardrive, so I have windows on the ssd, game in 320 gb in the hard drive and linux in 150 gbs) I divided it this way ( 50GB for root, 100 gb for home and 4 or 3 for swap + 535 for efi partition).

  5. After you finish installing the OS go to the bios menu and choose the boot manager of your preference.

  6. Choose start in recovery mode and then fix the packages, then resume.

  7. To enable wifi copy and paste this on the terminal

    echo blacklist asus-nb-wmi | sudo tee -a /etc/modprobe.d/blacklist-asus-nb-wmi.conf
    
  8. You must upgrade linux to the latest kernel so that you can be able to use the OS.

  9. That's it, backlight won't work and I still have 2 errors before the OS starts that I don't know how to fix.

Disclaimer: I don't have this laptop to try it out myself, but it sounds reasonable and the steps are understandable.

0

New Asus computers have OS Selection, you should change that from WINDOWS 8/10 to WINDOWS 7, that should work. I had the same problem. enter image description here

3
  • I can't remember exactly how is option called, but I know it has to choose between Windows 7 and 8/10. When I choose 7, linux installed.
    – Luka
    Commented Jan 28, 2017 at 18:43
  • no it can be set up win 7 or 8 on it! because of its drivers is just for win 10.
    – RayanFar
    Commented Apr 23, 2017 at 0:16
  • I am not talking here about installing windows, there is option called "OS SELECTION" or something similar in bios, which prevents installing another os than selected. If you have that option, choose windows 7 since most of the time there is no DISABLE option and it will install linux normally. I am talking from my personal experience with my asus laptop. I added image to my answer
    – Luka
    Commented Apr 23, 2017 at 18:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .