1

I tried installing VirtualBox 5.1 on Kali Linux 2016.2. I did this by running

                         apt-get install virtualbox

(I'm logged in as root, so no need for sudo). This worked fine, a few errors during the install, but the resulting app worked. I launched it, made a VM, and once I tried to run said VM, it told me it was missing a critical kernel driver (vboxdrv), and that I should run

                             modprobe vboxdrv

I did this, and the result was

modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.6.0-kali1-amd64

I tried running

dpkg-reconfigure virtualbox-dkms
apt-get --reinstall install virtualbox-dkms
service vboxdrv setup
apt-get install linux-headers-amd64
/etc/init.d/vboxdrv setup
apt-get install linux-headers-$(uname -r)

(Not in that order)

I also tried

dpkg -i virtualbox-5.1_5.1.14-112924~Debian~wheezy_amd64.deb

with the Debian Wheezy .deb file on the VirtualBox site, but that one didn't even start up.

None of these worked. Can anyone help me here?

  • 1
    Did you by any chance manually upgrade the kernel? – Julie Pelletier Jan 27 '17 at 17:01
4

Upgrade your kernel version :

Run : apt-cache search linux-image then install the latest version. e,g:

apt-get install linux-image-4.8.0-kali2-amd64

Install the linux-headers :

apt-get install linux-headers-4.8.0-kali2-amd64

Reboot your system

remove virtualbox , then reinstall it as follows:

apt-get update && apt-get upgrade && apt-get dist-upgrade
apt-get install dkms
apt-get install virtualbox virtualbox-dkms 
modprobe vboxdrv 
0

In addition to the virtualbox package, you need to install the virtualbox-dkms and virtualbox-qt (for GUI front end) packages... at least this is how it works on Mint and Ubuntu, which Kali is based on... Also Mint has an issue with the menu shortcut not showing up until you log off and log back in...

For your missing module issue, the virtualbox-dkms package is the critical one...

0

i tried to type 'apt-get install virtualbox-dkms' but at the end message : apt-get install linux-headers-4.6.0-kali1-686-pae (The last command may fail if your system is not fully updated.) apt-get install linux-headers-686-pae

There were problems setting up VirtualBox. To re-start the set-up process, run /sbin/vboxconfig as root. Errors were encountered while processing: virtualbox-5.1 E: Sub-process /usr/bin/dpkg returned an error code (1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.