0

I'm trying to install ImageMagick 6.4 on a new (Linux Mint 18) linux installation. I want 6.4 since that's the version we have on our server.

I downloaded a tar.gz, unzipped it, ran configure and then tried make. I instantly get a ton of errors like this:

$ make

make  all-am
make[1]: Entering directory '/home/max/software/imagemagick/6.4/ImageMagick-6.4.0'
/bin/bash ./libtool --silent --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I./config   -I/usr/include/freetype2 -I/usr/include/libxml2  -g -O2 -Wall -W -pthread -MT coders/coders_art_la-art.lo -MD -MP -MF coders/.deps/coders_art_la-art.Tpo -c -o coders/coders_art_la-art.lo `test -f 'coders/art.c' || echo './'`coders/art.c
In file included from coders/art.c:5
./magick/quantum-private.h: In function ‘PopDoublePixel’:
./magick/quantum-private.h:85:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
   *((double *) quantum)=(double) (pixel*quantum_state->scale+
   ^
./magick/quantum-private.h: In function ‘PopFloatPixel’:
./magick/quantum-private.h:115:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
   *((float *) quantum)=(float) ((double) pixel*quantum_state->scale+

In file included from magick/blob.c:65:0:
/usr/include/zlib.h:1536:30: note: expected ‘gzFile {aka struct gzFile_s *}’ but argument is of type ‘FILE * {aka struct _IO_FILE *}’
ZEXTERN const char * ZEXPORT gzerror OF((gzFile file, int *errnum));
                          ^

I don't really know much about compilation but these all look like some sort of fundamental failure to compile or run the code. There's tons of them. Can anyone guess what I'm missing, or what I've done wrong?

EDIT: The full output is here: http://pastebin.com/v01aj8hu

  • 1
    I see no actual error in that output, only warnings. If there's an error (which makes the compilation terminate), then maybe post that. – Kusalananda Jan 27 '17 at 16:32
  • I've added the full output in a pastebin, thanks. – Max Williams Jan 27 '17 at 16:39
  • Looks like it's trying to use zlib in the wrong way. Maybe it's expecting a newer version of zlib than what is available? IIRC, one may disable zlib support for ImageMagick with --without-zlib when configuring... But that may not be what you want to do. – Kusalananda Jan 27 '17 at 16:51
  • I just tried that as an experiment - still get tons of warning and errors and general full-of-fail... – Max Williams Jan 27 '17 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.