0

Hi I've installed debian 9 using virtualbox. I customized kernel with ACPI support as below

Power management and ACPI options  --->
    [*] ACPI (Advanced Configuration and Power Interface) Support  --->
        <M>   Button

When I click the close button of the virtualbox window with send the shutdown signal option, nothing happened

I make sure the kernel button module was inserted.

# lsmod | grep button
button                  5539  0

If I boot with debian's official kernel Linux debian 4.9.0-1-amd64 #1 SMP Debian 4.9.2-2 (2017-01-12) x86_64 GNU/Linux and send the shutdown signal option, everything works fine. systemd start to shutdown just like poweroff command do.

I also tried to modify /etc/systemd/logind.conf

HandlePowerKey=ignore

Then reboot and send the shutdown signal again, it was ignored as expected.

There is no acpid running to handle the event, and the systemd logind.conf take effect if I changed it, so the signal is only handled by systemd now.

How to make my customized recognize the shutdown signal? (only button module was compiled and loaded for it now.) Are there other kernel options needed?

1 Answer 1

1

I got it now, after tracing systemd source code src/login/logind-button.c seems it is related to /dev/input/

so i enable it in kernel config, and it can shutdown normally now.

Device Drivers  --->
    Input device support  --->
         <M>   Event interface

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .