Yesterday I created a commit in git, used git format-patch to create a patch and finally sent this patch as an email via mutt, using mutt -H <patch>. Somewhere along this chain my name, that contains an 'ö', got messed up. I need to find out where it got messed up and how to fix it.

This is my commit using git show <commit> (with some changes for privacy):

commit xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Author: Name Sandström <my@email.com>
Date:   Thu Jan 26 21:41:08 2017 +0100


Output of the file produced by git format-patch HEAD^:

From xxxxxxxxxxxxxxxxx Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Name=20Sandstr=C3=B6m?= <my@email.com>
Date: Thu, 26 Jan 2017 21:41:08 +0100
Subject: <commit subject>
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

After executing mutt -H <patch> and entering to and subject, mutt opens vim with this:

From: =?UTF-8?q?Name=20Sandstr=C3=B6m?= <my@email.com>
To: <to address>
Subject: <subject>


If I send this email to someone that uses e.g. Gmail, my name will show as =?UTF-8?q?Name=20Sandstr=C3=B6m?= in the web ui, and not Name Sandström which I expect.

I've tried both with having the mutt option send_charset unset and with having it set to us-ascii:utf-8, but the name still looks like above. The only difference I see is that the raw email contains Content-Type: text/plain; charset=iso-8859-1 when having send_charset unset and Content-Type: text/plain; charset=utf-8 when having send_charset set to us-ascii:utf-8.

How do I solve this? Who is doing something wrong here? git, mutt, Gmail or me?

Edit: I'm using:

Mutt 1.5.23
git version 2.11.0

Edit: It seems as if mutt is doing something wrong. mutt 1.7.1 seems to successfully decode my name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.