7

After starting a new session in my Debian Squeeze (6.0.4, always updated) running in a VM (VMWare Workstation) there comes the point in time where the left mouse click stops working, so that I cannot resize windows, bring them to front etc.

Sometimes I can switch window focus with the right click or with right-click and Control key held at the same time, but then it does not work at all.

Keys are accepted. I do not run anything special, just Emacs, Okular, Thunderbird and such stuff.

Unfortunately I cannot give any sequence of events which reliably creates the problem.

Is there a known fix to this problem (my googling efforts were not successful) or do i have to switch to KDE or LXFE?

4 Answers 4

5

I have the same issue and have not found a proper fix for this, what I end up doing is modprobe -r psmouse, then modprobe psmouse to get back control.

1
  • This works for me, but there has got to be a better fix.
    – radix07
    Feb 20, 2013 at 16:48
0

Make sure you're using the Xorg vmmouse driver, at minimum, or have VMware Tools installed.

0

[EDIT: I could swear I had some text as intro here; now it's gone, and there was no marker that anyone edited it? Maybe I've triggered some of website's auto-delete by saying "me too" or something :) Anyways, apologies I've forgotten what my intro should have been ... but basically this is what worked on my system]

$ lsusb | grep -i logitech
Bus 003 Device 003: ID 046d:c526 Logitech, Inc. Nano Receiver

# search by ID - make sure it's capital letters (or case insensitive)
#
$ find /sys/devices/ -iname '*046d*'
/sys/devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/0003:046D:C526.0002
/sys/devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.1/0003:046D:C526.0003

# look for all refs to "driver" 
# in /sys/devices/pci0000:00/0000:00:1d.1/usb3/3-1/
#
$ for ix in $(find /sys/devices/pci0000:00/0000:00:1d.1/usb3/3-1/ -name '*driver*'); do echo $ix; ls -la $ix; done
/sys/devices/..../usb3/3-1/driver
... 22:31 /sys/devices/..../usb3/3-1/driver -> ../../../../../bus/usb/drivers/usb
/sys/devices/..../usb3/3-1/3-1:1.0/driver
... 22:46 /sys/devices/..../usb3/3-1/3-1:1.0/driver -> ../../../../../../bus/usb/drivers/usbhid
/sys/devices/..../usb3/3-1/3-1:1.0/0003:046D:C526.0002/driver
... 22:46 /sys/devices/..../usb3/3-1/3-1:1.0/0003:046D:C526.0002/driver -> ../../../../../../../bus/hid/drivers/generic-usb
/sys/devices/..../usb3/3-1/3-1:1.1/driver
... 22:46 /sys/devices/..../usb3/3-1/3-1:1.1/driver -> ../../../../../../bus/usb/drivers/usbhid
/sys/devices/..../usb3/3-1/3-1:1.1/0003:046D:C526.0003/driver
... 22:46 /sys/devices/..../usb3/3-1/3-1:1.1/0003:046D:C526.0003/driver -> ../../../../../../../bus/hid/drivers/generic-usb

# list usb drivers given by `lsmod`
#
$ lsmod | grep usb
usbhid                 41704  0 
hid                    77084  1 usbhid
usb_storage            43946  0 

# it must be `usbhid` that is responsible - unload it:
#
$ sudo modprobe -r usbhid

# at this point, the USB wireless mouse wasn't moving 
# the pointer anymore (but touchpad was; also left click
# on touchpad started working here);
# load `usbhid` again
#
$ sudo modprobe usbhid

... and at this point, left click with the wireless USB mouse recovered for me.

0

Try adding the following two lines in your C:\Users\me\AppData\Roaming\VMware\preferences.ini file:

pref.motionGrab = "FALSE"

pref.motionUngrab = "FALSE"

Answer found here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.