6

I have trouble with the numeric keypad (NumLock keys) being unusable while typing.

While I don't think it's GUI specific, this happens both in Gnome and KDE. Sometimes it works in TTY, other times it fails. If I press the NumLock key nothing happens, and the response is the same.

I cannot use any of the keys except Ins, which repeats text after Backspace is used.

EDIT:

xev output, on NumLock press/release

KeyPress event, serial 33, synthetic NO, window 0x2800001,
    root 0x101, subw 0x0, time 389867, (311,217), root:(319,313),
    state 0x0, keycode 77 (keysym 0xff7f, Num_Lock), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x2800001,
    root 0x101, subw 0x0, time 389867, (311,217), root:(319,313),
    state 0x10, keycode 77 (keysym 0xff7f, Num_Lock), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
  • What does xev say when you run it and then press numlock? – Ulrich Schwarz Mar 13 '12 at 5:30
  • @UlrichSchwarz I have edited the question. – Joe Barr Mar 14 '12 at 23:49
  • That looks good, so it appears the keystroke is getting up to the X server, which then doesn't do anything with it. I'm stumped, I'm afraid. – Ulrich Schwarz Mar 15 '12 at 6:36

12 Answers 12

2

This command worked for me on Linux Mint 17 (Ubuntu 14.04) and 18 (Ubuntu 16.04) using XFCE with a CMStorm keyboard.

setxkbmap -option keypad:pointerkeys

setxkbmap - set the keyboard using the X Keyboard Extension

For some reason, activating numlock will make the keys move my mouse and deactivating numlock will set the keys to the correct characters. I suppose this is good because now I don't have to enable numlock and I can save a very small amount of electricity.

Source: https://forum.kde.org/viewtopic.php?f=216&t=106658

0

Is this a PS/2 keyboard being accessed from a USB adapter? The inexpensive ones always give trouble on keyboard that draw over 100ma from the system, such as the famous IBM Model M keyboard. For those you need a heavy-duty "active" adaptor, such as discussed at Geekhack, Deskthority and other keyboarding forums.

0

You may have accidentally enabled mouse keys (not sure if that's the right name for it). If it happens again, see if the keypad is moving the mouse (e.g. hold down the '4' and see if the mouse starts moving to the left), and try using shift-NumLock to turn that mode off.

  • mouse moves to left, but shift-numlock didn't work disable the mode - any other suggestions? – virtualxtc Jun 26 '14 at 0:55
0

There are some keyboard layouts that just don’t have the numlock key in use. For example the German neo layout which is part of de. Maybe you are using this or a similar layout.

0

Thanks to drewbenn and Ulrich Schwarz for helping me narrow down this problem.

Shift-numlock didn't work disable the mode for me, so I went hunting around the GUI for some sort of manual setting that I might be able to unenable.

In the "mouse KDE Control Module" (KMenu -> Computer tab -> System Settings -> Input Devices -> Mouse) there is a tab called "Mouse Navigation".

Unchecking the box next to "Move pointer with keyboard" solved the problem!!!

0

On Mint Cinnamon the part which changes from the KDE is that you have to go to (Gmenu -> System settings -> Accessibility -> Pointing and clicking )

There turn off the "Control the pointer using the keypad" option.

0

Try this program

https://packages.debian.org/sid/numlockx

On my system works,fine,on X and tty

0

I accidentally disabled the numeric keypad.
To allow the numbers to work again, I did the following:

  1. Go to mouse settings
  2. Mouse/ Touchpad ===> choose Mouse
  3. The "Show position of pointer when control is pressed" checkbox should be in the [off] position
0

Fedora 27= >Settings >Universal Access >Mouse Keys=Off That fixed it when using my USB keyboard with 10 key pad. None of the combinations with "Num Lock" had any effect until I turned Mouse Keys off.

0

Kali-Linux v2018.1:

Universal Access > Pointing and Clicking > Off

These steps will give you the option to turn on numlock manually. This is not to enable automatic numlock on start-up. However, it will give you the ability to once again use the numbers pad.

0

On Fedora 30: Configuration (or Setup, I'm not sure) > Devices > Mouse & touchpad > turn off touchpad. Bingo! Numerical pad is now working!

-1

Nothing suggested above works. I accessed universal access, turned off mouse keys, and the numb pad works again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.